Language:
Page Info
Engine Version:
The translation of this page is out of date. Please see the English version for the latest version of the page.

UE4 に Visual Studio を設定する方法

UE4 は、Visual Studio とスムーズな統合ができるように設計されています。プロジェクトで迅速かつ簡単にコード変更を行い、コンパイルしてその結果を直ちに確認することができます。 Visual Studioを UE4 と連携させるように設定することで、デベロッパーの効率と全体的なユーザー体験を向上させることができます。

このドキュメントでは、UE4 と VS2013 ワークフローの設定の基礎について取り上げます。

UE4 と VS のワークフローを設定する前に

Visual Studio 2015 (VS2015) は、デフォルトでは C++ ツール サポートをインストールしません。VS2015 をインストールする場合は、Custom インストールを選択して、各自のワークフローで必要となる C++ コンポーネントを選んでください。 Visual Studio 2015 をインストール済みの場合は、File > New > Project > C++ の順に選択して C++ をインストールしてください。

以下の表は、どのバージョンの Visual Studio が UE4 のバイナリ バージョンと統合されているかを一覧表示しています。

アンリアル エンジンのバージョン

Visual Studio のバージョン

4.10 以降

VS2015

4.2 から 4.9

VS2013

UE4 のオープン ソース バージョン (GitHub および P4 から入手可能) は、VS2013 と統合されています。Visual Studio のこれより古いバージョンと統合されている、UE4 の古いバージョンについては、このドキュメントでは扱いません。

推奨設定

以下は UE4 で Visual Studio を使用するデベロッパーへの推奨設定です。

  1. 以下の手順に従い、Solution Configurations ドロップダウン メニューの幅を広げます。

    1. ツールバーを右クリックして、表示されるメニューの下部の [カスタマイズ] を選択します。

      SelectingCustomize.png

    2. [コマンド] タブをクリックします。

      ClickCommandsTab.png

    3. [ツールバー] ラジオボタンを選択します。

      SelectToolbarRadioButton.png

    4. ツールバー の横のドロップダウンから、[Standard] を選択します。

      SelectStandard.png

    5. 下にある コントロール リストから Solution Configurations コントロールを選びます。

      SelectSolutionConfigControl.png

    6. 右側の [Modify Selection] を選択します。

      ClickModifySelection.png

    7. を '200' に設定します。

      SetWidth_200.png

    8. [Close] をクリックします。ツールバーが直ちに更新されます。

      ClickClosetoUpdateToolbar.png

  2. 以下の手順に従い、Solution Platforms ドロップダウンを追加します。

    1. 標準ツールバーの右端のボタンで、ツールバーのボタンを追加 / 削除するドロップダウン メニューが開きます。

      SelectDropDownButton.png

    2. ドロップダウン ボタンをクリックして、[Add or Remove Buttons] 上にカーソルを合わせて、[Solution Platforms] をクリックしてツールバーにメニューを追加します。

      SelectSolutionPlatforms.png

  3. [Error List] ウィンドウをオフにすることをお勧めします。通常、コードにエラーがあると自動的に [Error List] ウィンドウが表示されます。ただし、アンリアル エンジンでの作業中は、誤ったエラー情報が [Error List] ウィンドウに表示されることがあります。この [Error List] ウィンドウを無効にして、[Output] ウィンドウを使ってアンリアル エンジンで作業する際に実際のコード エラーを表示させると良いでしょう。以下の手順では、[Error List] ウィンドウを閉じる方法を説明します。

    1. 開いている場合は [Error List] ウィンドウを閉じます。

    2. [ツール] メニューから [オプション]ダイアログを開きます。 OpenOptionsDialog.png

    3. [Projects and Solutions (プロジェクトとソリューション)] を選択して [Always show error list if build finishes with error (ビルドがエラーで終わった場合、常にエラー リストを表示する)] のチェックを外します。 UncheckErrorsListOption.png

    4. [OK] をクリックします。

他に役立つ設定手順として以下があります。

  • [Show Inactive Blocks] をオフにします。このオプションをオンのままにすると、多数のコードチャンクがテキスト エディタでグレーアウトされることがあります。(Tools > Options > Text Editor > C/C++ > View).

  • Solution Explorer で不要なフォルダを非表示にするには、[Disable External Dependencies Folders] を True に設定します。(Disable External Dependencies Folder in Tools > Options > Text Editor > C/C++ > Advanced)

  • Edit & Continue 機能も必要ないのでオフにします。(Tools > Options > Debugging > Edit and Continue)

  • インテリセンス (IntelliSense) をオンにします。(Intellisense、 Live Errors、 および Squiggles を参照してください。)

Visual Assist X ユーザー向けの推奨

Visual Assist X がインストールされている場合は以下を行います。

  • Format After Paste (VAssistX > Visual Assist X Options > Advanced > Corrections) を無効にします。このオプションを無効にしないと 「Visual Assist X 」がソース コードを自動的にフォーマットしてしまいます。その結果、ドキュメントが適切にフォーマットされないおそれがあります。

Intellisense、 Live Errors、 および Squiggles

UE4 プロジェクトは、IntelliSense を正式サポートするようになりました。このサポートには、ライブエラーリストと「Squiggles」も含まれます (有効にする方法は以下を参照してください)。

IntelliSense は、ユーザーが入力する C++ コードを再コンパイルします。コードの全てのラインを検証するフル C++ コンパイラを使用しているため、 VAX の構文チェック機能のみよりもより強力な機能です。大変すばらしい機能であり、 ワークフローの迅速化が図れます!

VC++ Intellisense Squiggles

Squiggles に加えて、閲覧しているファイルのエラー リストに IntelliSense エラーも表示されます。 このオプションは Error List の 右クリック メニューで、オンオフを切り替えることが出来ます。

Error List

Squiggles は UE4 プロジェクトで動作しなかったため、既に無効に設定されているかもしれません。[C/C++ Advanced] タブを押して、 下記のような設定必ずしてください。

VC++ Advanced Options

C++ ファイルを開いたとき、以下のアイコンが表示されることで IntelliSense コンパイラーが「実行」されていることがわかります。

Intellisense Progress Indicator

実装の詳細

  • コード編集時に、Squiggles が表示されるまでに数秒かかる場合があります。

    • 大量のインクルード ファイルが存在し、現状では IntelliSense は PCH を使用しないためです。

  • 時々 IntelliSense の「false positive」エラーが発生します。このエラー発生にはいくつかの理由が考えられます。

    • IntelliSense コンパイラー (EDG) は、MSVC コンパイラーよりも厳格です。

    • IntelliSense では、通常のビルド時とは異なる「#defines」の設定がいくつかあります。

    • IntelliSense でコンパイルされる C++ は、常に 32 ビットで生成されます。

  • 絶対に必要ならば、コードを「#ifdef __INTELLISENSE__」でラップして Squiggle を非表示にすることが出来ます。

  • IntelliSense エラーは、VC++ コンパイラーのエラーとは若干異なる表現法が使用されます。単にそのような設定となっています。

  • ヘッダファイルの Squiggles は、ヘッダをインクルードする「.cpp」に対して、ヘッダをコンパイルすることによって機能します。

    • 時々 IntelliSense はこれに失敗し、 Squiggles がヘッダに含まれている場合があります。

  • 必要に応じて増加することができる Max Cached Translation Units 設定 (上記に表示) があります。

    • メモリの消費が多くなりますが、応答性が若干向上することがあります。

  • 未だ IntelliSense に対応しない C++ ファイルもいくつかあります。

  • アンリアル ビルド ツールに、「-IntelliSense」オプションが新規に加わりました。

    • 全てのプロジェクト ファイルに対し、IntelliSense プロパティシートを出力します。

    • 新しいモジュールの追加、またプロジェクトに含まれるものに変更があった時のみ再実行が必要です。

UnrealVS 拡張機能

Visual Studio に対応する UnrealVS 拡張により、アンリアル エンジン 4 (UE4) を使った開発では、一般的な操作に簡単にアクセスできるようになりました。

unrealvs_toolbar_cmd.png

以下の機能があります。

  • スタートアップ プロジェクトの設定

  • スタートアップ プロジェクトをビルドするためのスタートアップ プロジェクトのビルド後に実行するコマンドの設定

  • コマンド ライン引数の設定

  • プロジェクトのバッチビルド

  • クイックビルド プロジェクト メニュー

UnrealVS 拡張は Visual Studio Express 版と連動しません。Visual Studio Community と Visual Studio Professional とのみ互換性があります。

設定と拡張機能の使用に関する情報は、UnrealVS 拡張 ページを参照してください。

デバッグ作業

Visual Studio にはビジュアライザでデバッガを拡張するサポートがあり、FName や動的配列など一般的 Unreal の型の調査を容易にします。

UE4 Visualizer for Visual Studio 2013 をインストールする

この UE4 Visualizer のインストールには、二段階のプロセスがあります。

  1. インストールの一部としてビジュアライザーロジックを含むファイルを探します。

    • [UE4Root]/Engine/Extras/VisualStudioDebugging/UE4.natvis

  2. UE4.natvis を以下のいずれかの場所にコピーします。

    • [VisualStudioInstallPath]/Common7/Packages/Debugger/Visualizers/UE4.natvis

    • [UserProfile]/My Documents/Visual Studio 2013/Visualizers/UE4.natvis

Visual Studio のインストール ディレクトリへコピーするには、管理者からのアクセス許可が必要な場合があります。