Sequencer编辑器引用

Sequencer编辑器的UI和控制引用页面。

Windows
MacOS
Linux

此页面概述了Sequencer编辑器中包含的界面元素和选项,可帮助您了解Sequencer中每个不同的界面元素及可用选项。

Sequencer编辑器界面

SequencerEditorCallouts.png

由于全新 关卡序列 不包含任何内容,因此上图只用于展示。

  1. 工具栏

  2. 序列Breadcrumbs

  3. 添加/过滤轨迹

  4. 时间轴

  5. 树状图

  6. 轨迹区域(Tracks Area)

  7. 播放控件

工具栏

Toolbar.png

以下是对工具栏上从左到右所列示之各个工具栏按钮的说明。

图标

说明

tb_1.png

保存当前关卡序列。

tb_2.png

用不同的名称保存当前关卡序列。

SearchIcon.png

在内容浏览器中查找当前查看的序列资源。

cameraicon.png

创建一个新摄像机,并将其设置为当前摄像机切换。

tb_4.png

打开渲染视频设置(Render Movie Settings)窗口,该窗口允许您将序列输出为电影或图像序列。

UndoIcon.png

将任何由sequencer动画化的对象恢复到其原始状态(Ctrl+R)。

tb_5.png

打开"通用选项(General Options)"菜单,其中包含用于定义Sequencer功能的设置。

PlaybackIcon.png

打开播放选项(Playback Options)菜单。

SelectEditOptions.png

打开选择/编辑选项(Select/Edit Options)菜单。

tb_6.png

启用/禁用全部设置关键帧(Key All)选项。启用此选项和启用自动设置关键帧后,将确定在进行更改时是否为所有属性设置关键帧,还是仅为更改的属性设置关键帧。

tb_7.png

启用/禁用不同的自动设置关键帧(Auto-Key)选项。默认情况下,此选项是禁用的,但可以设置为自动全部设置关键帧(Auto-key All)或对动画化项自动设置关键帧(Auto-key Animated)。

SequenceEditOptions.png

打开序列编辑选项(Sequence Edit Options)菜单。

tb_8.png

启用/禁用轨迹区域的网格对齐以及网格对齐选项。

tb_9.png

允许调整时间对齐间隔。

tb_10.png

打开曲线编辑器 ,它允许您微调放置在轨迹区域的动画关键帧。

Sequencer曲线编辑器

在曲线编辑器中使用切线时,浮点曲线上支持加权切线,如下图所示。

WeightedCurves_03.gif

曲线编辑器还支持变更旋转时欧拉角连续变化。欧拉角不限于-180、180,是避免在动画中翻转的必须设置。

可在3D变形分段上通过轨迹的 属性 菜单打开 四元数旋转,利用四元数插值在两个旋转间平滑插值。

可停靠曲线编辑器窗口

与编辑器中的其他面板一样,曲线编辑器窗口也可移除和停靠。关闭Sequencer或编辑器时,将保存曲线编辑器的位置;重新打开Sequencer时,曲线编辑器将恢复到所保存的位置。

NewCurveEditorDockable1.png

视图模式

点击 视图模式(View Mode) 按钮可选择所选曲线的显示方式,如下所示。视图模式分三种:

  • 绝对视图(Absolute View) 显示绝对空间中绘制的所有曲线——这符合大家习惯的传统行为。

  • 堆叠视图(Stacked View) 将每条曲线规格化,然后不重叠地绘制曲线。

  • 规格化视图(Normalized View) 将每条曲线规格化(如堆叠视图),但将曲线彼此重叠地绘制。

点击查看大图。

过滤器菜单

使用 过滤器菜单(Filter Menu)可将不同过滤器应用于选定选项。此菜单自身拥有浮动对话框,支持完整的细节面板。在其中可进行广泛设置。其在点击 应用(Apply) 按钮后也会继续存在,因此可方便地对设置进行迭代。在此对话框中添加新选项与在由 UCurveEditorFilterBase 派生的新类上实现一个函数同样简单。

点击查看大图。

多帧选项

曲线编辑器中有多帧选项。帧选择(无选择则为 所有帧(Frame All))为内置,默认为F键。播放光标上的帧(Frame on Playback Cursor)播放范围上的帧(Frame on Playback Range) 为新增选项。它们是使用插件扩展工具栏的完美示例。旧的 帧水平/帧垂直(Frame Horizontal/Frame Vertical) 选项已替换为 聚焦全部(Focus All),按住ALT + SHIFT + 鼠标右键即可对每个轴进行独立缩放。也可在聚焦全部后按住ALT + 鼠标右键,进行等比缩放。

调时工具

调时工具 将创建一维框架,用于调整关键帧的时间。其支持网格对齐、多选和其他选项。此工具由默认插件提供。

点击查看大图。

变换工具

变换工具可平移选定关键帧,也支持在X轴和Y轴上对其进行缩放(如位置合适)。按住 Alt 键可将锚点从对边改为中心。

点击查看大图。

操纵曲线

您可以通过多种方式操纵曲线:手动调整曲线键,或输入不同的曲线键值。

曲线与网格的对齐将基于网格的间距。您可以随时使用 值对齐 图标旁边的下拉菜单来修改网格间距,并相应地调整曲线。

网格间距和全新对齐

如果在选择了多个键的情况下使用变换工具,可以使用 工具选项,修改 上边界下边界左边界右边界缩放X和Y衰减插值 来调整边界、缩放中心并衰减值。 上边界下边界 可以调整曲线的上下范围。左边界右边界 可以调整曲线序列的起始时间。缩放中心X和Y 可以沿网格的X轴和Y轴移动曲线缩放中心。

衰减插值类型 可使用以下任一衰减类型来调整曲线的衰减率:线性、正弦曲线、循环进出(Circular In/Out)和指数进出(Exp In/Out)。在动画混合模式 中可以了解这些衰减类型的详细信息。

点击查看大图。

若使用多选工具并选择了多个键,则可以通过 工具选项 更改 XY 缩放及 枢轴类型

X和Y缩放可调整X轴和Y轴上的曲线。有四种枢轴类型可选择:

  • 平均:曲线将针对键的平均位置缩放。

  • 边界中心:曲线将针对中值键的平均位置缩放。

  • 第一个键:枢轴基于第一个键。

  • 最后一个键:枢轴基于最后一个键。

点击查看大图。

保存曲线

右键点击曲线键可以 保存曲线,以便拍摄曲线数据的快照。

保存曲线选项

也可以 应用保存曲线 数据到另一曲线,操作类似于复制/粘贴数据。 调整曲线时,原始快照仍会作为参考点保留在网格视图中。

序列Breadcrumbs

可能会存在一个"主"关卡序列,其中包含关卡序列一部分的 镜头,具体视工作流而定。在这种情况下,可以双击轨迹区域中的镜头(Shot),直接前往特定镜头。

在下图中,另一个关卡序列内包含着一个关卡序列,前者正是我们的"主"序列。 点击第一个breadcrumb便能返回包含所有镜头的主关卡序列。点击文件夹图标可以前往层级中的任何关卡序列。

breadcrumb导航选项

添加/过滤轨迹

轨迹(Track) 按钮允许您从您的关卡将添加 轨迹(Tracks)ActorSequencer,然后您可以使用该Sequencer来制作您的过场动画。

AddOption.png

当您选中的关卡中有Actor时,请单击 轨迹(Track) 按钮并在 Actor到Sequencer(Actor to Sequencer) 下查看,您所选择的Actor将显示在上下文菜单的最上方,以便您快速添加它。 如果所选的关卡中没有Actor,在单击 Actor到Sequencer(Actor to Sequencer) 时,您仍可以从上下文菜单中选择该关卡中存在的任何其他Actor。

以下是您可以添加到Sequencer的可用轨迹,单击下面的各个链接可查看使用各个轨迹之示例的指导页面。

轨迹

说明

添加文件夹(Add Folder)

您可以添加文件夹,以包含用于组织目的的轨迹。

音频轨迹

添加可用于播放声音的主音频轨迹。

事件轨迹

添加可用于发出信号和启动蓝图脚本的轨迹示例。

摄像机切换轨迹

允许您在与Sequencer相关的摄像机之间切换,并提供摄像机视角。

镜头轨迹

允许您添加关卡序列作为"镜头",镜头中可以有可以交换进来或出去的 拍摄

播放速率轨迹

添加可用于操作序列的播放速率的轨迹。

子场景轨迹

添加可以包含其他关卡序列的子轨迹。这对于创建一个序列的多个副本非常有用,不同的用户可以在不更改原始序列的情况下使用这些副本。

消退轨迹

添加一个使您可以控制序列淡入/淡出的轨迹。

关卡可视性轨迹

此轨迹可以用于设置关键帧和控制关卡的可见性。

材质参数集轨迹

此轨迹可用于驱动Sequencer内的材质参数集。

利用 过滤器 选项可选择和查看添加到序列的特定轨迹。

filter.png filters_on.png

还可 搜索 轨迹,此功能也可过滤序列中的Actor。

search.png

时间轴

Timeline.png

时间轴(Timeline)绿色(Green)(开始)和 红色(Red)(结束)标记指示序列的播放范围。序列的当前时间由时间轴标记指示,您可以通过单击鼠标左键沿时间轴拖动来擦除该标记。

您可以右键单击时间轴,从上下文菜单中定义新的开始点/停止点,如下图所示。

Timeline2.png

即使您的内容没有完全达到序列结尾(或超过结束标记),您的序列都将从开始标记继续播放一直到结束标记。 在 播放选项(Playback Options) 中,有一个选项可以将内容保持在片段边界内,这将确保在序列期间没有死空间。

KeepInSectionBounds.png

树状图

树状图(Tree View) 是您确定在序列期间要执行的操作类型之处。

tracks1.png

在上图中,我们有一个 摄像机切换 轨迹,用于在我们的序列期间切换摄像机角度,有一个 动画摄像机Actor(Cine Camera Actor) 提供场景的视图,以及两个 骨架网格体Actor(Skeletal Mesh Actors)(它们是我们的场景中的角色)。

Sequencer是上下文相关的,它将允许您添加子轨迹(如果适用)到每个轨迹,这些轨迹将为您提供额外的选项。 例如,在下图中,我们添加了一个 摄像机组件(CameraComponent) 轨迹到我们的动画摄像机Actor(Cine Camera Actor)中,这使我们能够添加另一个子轨迹来调整我们的场景中摄像机的一些属性(如果我们希望如此)。

tracks2.png

您还可以从树状图中为您的轨迹添加关键帧,以在时间轴上的特定点定义属性。

AddKeyFrameButton.png

您可以单击 + 关键帧按钮或在选定轨迹后按下 Enter 键。

轨迹区域

KeyframeWindow.png

轨迹区域(Tracks Area) 是调整各个轨迹内容的地方。您可以调整添加的任何关键帧,剪辑/分割、锥入/锥出分段以及 右键单击 上下文菜单(如下图所示)中的其他几个选项。

RightClickContext1.png

在上图中,在变形轨迹的关键帧上 右键单击,可以更改关键帧插值类型以及可以从 属性(Properties) 界面中调整的其他选项,这些选项根据您右键单击的内容类型进行更新。

在下图中,右键单击 分配到动画轨迹的动画并选择属性,可以更改当前分配的动画,以及调整与动画本身相关的属性,如开始/结束偏移值和播放速率等。

RightClickProperties.png

导航轨迹区域

以下是您可以用来导航轨迹区域的方法和快捷方式。

命令

说明

右键单击拖动

允许你在轨迹区中随意移动。

Ctrl + 鼠标滚轮上下滚动

在轨迹区中放大/缩小。

Home 键

重置轨迹区的缩放/视图范围。

-=

以 10% 为增量缩放视图范围。

,.

在设置的关键帧之间前后移动。

左键单击拖动

在窗口中的键周围创建一个选择框。

左键单击

选中该键。

右键单击

显示快捷菜单,你可在其中定义该键的属性。

按鼠标中键

在鼠标所在位置创建一个关键帧。

Enter 键

在所选轨道的当前时间位置设置一个键。

Ctrl + G

转到序列中设定的时间/帧。

I

设置选择范围的起点。

O

设置选择范围的终点。

M

在鼠标当前位置添加/移除一个帧标记。

Ctrl + Shift + , (逗号键)

将时间轴跳转到上一个标记处。

Ctrl + Shift + . (句号键)

将时间轴跳转到下一个标记处。

Ctrl + 左箭头

将选中的关键帧和分段向左移动一帧。

Ctrl + 右箭头

将选中的关键帧和分段向右移动一帧。

有关键盘绑定和其他快捷方式的完整列表,请参阅Sequencer速查表 页面。

播放控件

PlaybackControls.png

播放控件(Playback Controls) 可以在Sequencer编辑器的左下角找到,它与标准媒体播放器应用程序类似。如果使用默认的虚幻编辑器布局,主关卡视口中也会显示相同的播放控件。 最后,使用过场动画视口 时,播放控件将显示在视口内部。

标准播放控件(Standard Playback Controls)如下所示:

命令

说明

playback1.png

将播放开始位置设置为时间标记所指示的当前位置。

playback2.png

跳转到播放开始位置。

playback3.png

跳转到所选轨迹的前一个关键帧。

playback4.png

跳转到上一个帧。

playback5.png

从时间标记的位置播放或暂停关卡序列。

playback6.png

向前跳一帧。

playback7.png

跳转到所选轨迹中的下一个关键帧。

playback8.png

跳转到播放结束位置。

playback9.png

将播放结束位置设置为时间标记所指示的当前位置。

playback10b.png / playback10.png

播放期间在循环关卡序列之间切换。

过场动画视口内播放控件的功能与上面相同。

Tags
Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback