LiDAR点云插件入门指南

LiDAR点云插件的快速入门指南。

Windows
MacOS
Linux

概述

本指南将介绍启用插件、导入点云并将其放入场景,以及编辑点云的过程。

1-启用插件Enabling the Plugin

LiDAR点云插件是内置在虚幻引擎中的,但在使用前需要先启用。

  1. 首先前往 编辑(Edit) > 插件(Plugins),打开 插件(Plugins) 菜单。

  2. 在插件(Plugins)菜单中找到 渲染(Rendering) 部分,然后找到 LiDAR点云支持(LiDAR Point Cloud Support),点击 启用(Enabled) 复选框。

    Enable_plugin.png

  3. 在启用插件后,你需要重启引擎。

分段结果

插件已启用,现在可以导入点云了。

2 - 导入并准备点云

要在UE4中使用点云,必须先将其导入引擎。出于本指南的演示目的,我们要让导入的点云扫描数据四处移动,所以还需要启用碰撞。

  1. 新建项目。

  2. 选择要导入的点云文件,然后拖到内容浏览器中。

  3. 将点云从内容浏览器拖入 视口(Viewport)。此操作将自动创建 LidarPointCloudActor 的实例,并为其分配用户指定的云。

  4. 在内容浏览器中右键点击 点云(Point Cloud),然后选择 编辑(Edit)

  5. 点击 碰撞(Collison),然后从下拉菜单中选择 构建碰撞(Build Collision)

    Build_Collision.png

  6. 在地面上方放置 玩家出生点(Player Start)

  7. 点击 运行(Play) 以开始 在编辑器中运行(Play-in-Editor) 模式,并在导入的扫描中移动。

分段结果

点云现已导入,而且具备了玩家碰撞,你现在可以随意探索导入的扫描数据了。在四处移动的过程中,你可能会发现一些需要修改的内容。接下来,我们就将了解如何对点云进行简单编辑。

Quickstart_Result.png

3 - 编辑点云

在使用点云的过程中,你可能需要修改它以满足自身需求。此时,可启用 编辑模式(Edit Mode) 来对导入的云进行修改。

  1. 右键点击内容浏览器中的 点云(Point Cloud) 并选择 编辑(Edit)

  2. 点击 编辑模式(Edit Mode).

  3. 要编辑点云,必须先将其完整加载到内存中。在提示框弹出时,请点击

  4. 启用编辑模式后,就可以编辑单个点或选中的一组点了。

    Enable_editing.PNG

  5. 按住 Shift 键拖动鼠标,就能选中要编辑的点。选中的点会以橙色高亮显示。

    selected_edit.PNG

  6. 然后就可以 隐藏删除提取 选中的点了。

编辑过的点必须重新构建碰撞。

分段结果

你选中了点并编辑了点云。

自己动手

现在,你已经启用了LiDAR点云插件,添加了碰撞,尝试了移动并编辑了导入的点云。

Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见