美术师快速入门

了解作为内容创建者如何开始使用虚幻引擎4。

Windows
MacOS
Linux
前置主题

此页面假定您已掌握以下主题的前置知识。请在继续之前先阅读它们。

MaterialsHeader_1.png

本快速入门指南展示如何将资源添加到虚幻引擎4(UE4)游戏中。在学习完本指南后,您将会了解如何使用 项目浏览器(Project Browser) 创建新项目,以及如何通过浏览 内容浏览器(Content Browser) 查找和添加内容。您还会学习如何查找 FBX内容通道(FBX Content Pipeline) 相关信息,以及如何在将 材质(Materials) 应用到 静态网格物体Actor(Static Mesh Actor) 之前,使用 材质编辑器(Material Editor) 修改 材质(Materials)

经常保存,尽早保存!

1. 必要的项目设置

  1. 从启动器打开 虚幻引擎(Unreal Engine)。将出现项目浏览器

  2. 单击 新建项目(New Project) 选项卡,然后选择 C++ 选项卡。然后,选择 基础代码(Basic Code),以便我们有一个干净的起点,并确保设置了 具有初学者内容(With Starter Content)。我们需要输入一个项目名称,所以我们将使用“QuickStart”。我们现在可以单击 创建项目(Create Project) 并开始制作。

    CreateProject.png

虚幻编辑器(Unreal Editor) 现在将打开我们的新项目。Visual Studio 也将打开并加载我们的项目创建的解决方案文件。

2. 创建文件夹

保持项目内容有条不紊始终是一种良好的做法。您首先要学习的是如何创建一个文件夹来存储导入的内容。

在开始之前:请从以下链接下载快速入门资源(Quick Start Assets)。

  1. 将下载的资源解压缩到计算机上的某个位置。

    ExtractedContent.png

    ExtractedContent_Mac.png

  2. 从编辑器内的 内容浏览器(Content Browser) 中,单击 新增(Add New) 按钮。

    AddNewButton.png

  3. 选择 新建文件夹(New Folder) 以在 “/Game” 中创建一个新文件夹。

    NewFolderSelection.png

  4. 将该文件夹命名为 “QuickStartContent”

    QuickStartContentFolder.png

  5. 双击该 “QuickStartContent” 文件夹。

命名惯例很重要!命名文件夹和文件时请遵循这些惯例。

3. 导入网格体

将内容添加到UE4项目的方法有几种;但我们将着重介绍内容浏览器的 导入(Import) 功能。

  1. 'QuickStartContent' 文件夹中单击内容浏览器的 导入(Import) 按钮打开文件对话框。

    ContentBrowserImportButton.png

  2. 找到并选择 Basic_Asset1Basic_Asset2 FBX网格体文件。

    ImportMeshDialogBox.png

  3. 单击 打开(Open) 开始将FBX网格体文件导入到您的项目中。

  4. 编辑器中将显示 FBX导入选项(FBX Import Options) 对话框。单击 导入(Import)全部导入(Import All) 会将您的网格体添加到项目。

    FBXImportOptionsDialogBox.png

  5. 单击 全部保存(Save All) 按钮保存已导入的网格体。

    SaveAllMeshesButton.png

  6. 将显示 保存内容(Save Content) 对话框。单击 保存选中项(Save Selected) 保存导入的资源。

    SaveSelectedDialogBox.png

  7. 导航到 'QuickStartContent' 文件夹,验证UE4创建了对应的 .uasset files

    QuickStartContentFolder.png

整理您的资源,以便轻松找到它们。

4. 导入纹理

  1. 在编辑器中导航到 'QuickStartContent' 文件夹,单击内容浏览器的 导入(Import) 按钮打开文件对话框。

    ContentBrowserImportButton.png

  2. 找到并选择 T_Rock_04_DT_Rock_04_n Targa (TGA)图像文件。

    ImportTextureDialogBox.png

  3. 单击 打开(Open) 开始将TGA图像文件导入项目。

  4. 虚幻编辑器的右下角将出现一个确认框。

    TextureNormalConfirmation.png

  5. 单击 确定(OK) 接受 T_Rock_04_n.TGA 法线贴图的设置。

  6. 单击 全部保存(Save All) 按钮保存导入的图像。

    SaveAllTextures.png

  7. 将显示 保存内容(Save Content) 对话框。

    SaveSelectedDialogBox.png

  8. 单击 保存选中项(Save Selected) 保存导入的资源。

  9. 导航到 'QuickStartContent' 文件夹,验证UE4创建了对应的 .uasset files

    QuickStartContentFolder.png

市场(可从 'Epic Launcher' 访问)是查找和分享内容的好地方。

5. 准备网格体以供导入

如果您有自己的网格体需要导入,请参阅此部分。

UE4 FBX导入通道使用 FBX 2018。在导出过程中使用不同的版本可能会导致不兼容。

选择3D美术工具

Autodesk Maya

Autodesk 3ds Max

  1. 在视口中选择要导出的网格体。

    maya_export_1.png

  2. 文件(File) 菜单中,选择 导出当前选择(Export Selection)(如果需要无视选择导出场景中的所有内容,则选择 全部导出(Export All))。

    maya_export_2.png

  3. 导出(Export) 对话框中:

    • 选择UE4项目中的 内容(Content) 文件夹(1)

    • 为文件输入一个名称并将其设为FBX导出(2)

    • 设置导出选项(3)

    • 单击 全部导出(Export All)(4)

    maya_export_3.png

    上述几何体类型中的设置是将 静态网格体(Static Meshes) 导出到虚幻引擎4的最基础要求。

  4. 浏览到项目的 内容(Content) 文件夹。您将看到您的FBX文件已添加。

    maya_export_4.png

  5. 您可以保留默认的导入选项。请参阅FBX导入选项参考,了解各个选项的详情。

  6. 您的资源现在已经导入,您可以将其从 内容浏览器(Content Browser) 拖放到您的关卡中。

    max_export_7.png

    上例中(作为导入选项的一部分)导入了 材质(Materials)纹理(Textures)

  1. 在视口中选择要导出的网格体。

    max_export_1.png

  2. 文件(File) 菜单中,选择 导出选定项(Export Selected)(如果需要无视选择导出场景中的所有内容,则选择 导出(Export))。

    max_export_2.png

  3. 选择UE4项目中的 内容(Content) 文件夹(1)和FBX文件的名称(2),然后单击max_save_button.jpg按钮。

    max_export_3.png

  4. FBX导出(FBX Export) 对话框中设置选项,然后单击max_ok_button.jpg按钮创建包含网格体的FBX文件。

    max_export_4.png

    上述几何体类型中的设置是将 静态网格体(Static Meshes) 导出到虚幻引擎4的最基础要求。

  5. 您可以保留默认的导入选项。请参阅FBX导入选项参考,了解各个选项的详情。

  6. 您的资源现在已经导入,您可以将其从 内容浏览器(Content Browser) 拖放到您的关卡中。

    max_export_7.png

    上例中(作为导入选项的一部分)导入了 材质(Materials)纹理(Textures)

非常好!您已学会如何准备网格体以供导入UE4。

如要了解有关FBX内容通道的更多信息,请单击此处。

简洁的建模提高了游戏性能。

6. 创建材质

材质(Materials) 是应用于网格体的资源,有助于场景的视觉美感。
有数种方法可以为您的UE4项目创建和编辑材质;不过我们将重点介绍如何使用 材质编辑器(Material Editor)

  1. 导航至您的 内容浏览器(Content Browser),单击 新增(Add New) 并选择 材质(Material)

    newCreateMaterial.png

  2. 将您的材质命名为 “岩石”

    materialNaming.png

  3. 您的 “岩石”材质 现在即可使用。

    NewRockMaterial.png

  4. 双击 “岩石”材质 将打开材质编辑器

    如果想要了解有关处理材质节点的更多信息,请阅读我们的材质-教程文档。

请使用2的幂调整纹理大小。

7. 编辑材质

现在,您应该已经创建了一个新材质并打开了 材质编辑器(Material Editor)

您可以在材质编辑器中定义材质的颜色、光泽、透明度等。现在您即可编辑您创建的 “岩石”材质

  1. 材质图表(Material Graph) 的中心选择 主材质节点(Main Material Node)材质编辑器(Material Editor) 将在您选择节点时为您突出显示该节点。

    newMainNode.png

    它是图表中唯一的节点(以您的材料命名)。

  2. 详细信息(Details) 面板中,将 着色模型(Shading Model)默认光照(Default Lit) 更改为 次表面(Subsurface)

    selectSubsurface.png

  3. 次表面着色模型(Subsurface Shading Model)主材质节点(Main Material Node) 中启用两个引脚:不透明度(Opacity)次表面颜色(Subsurface Color)

    newMorePins.png

  4. 现在是时候把您的纹理放到图表中了。按住 “T” 键并在编辑器的图表区域内单击鼠标左键。纹理样本节点(Texture Sample Node) 应显示在图表中。

    TextureSample.png

  5. 您至少需要2个纹理。重复步骤4,直至您的图表如下图所示。

    newTextureSampleNodes.png

  6. 选择其中一个 纹理样本节点(Texture Sample Nodes) 并在 详细信息面板(Details Panel) 下找到 材质表达式纹理基础(Material Expression Texture Base) 类别。

    matExpressionTextureBase.png

    在纹理属性下,单击标签为 “无” 的下拉菜单,并选择名为 T_Rock_04_D 的颜色纹理。

    您还可以通过在搜索字段中输入 'T_Rock_04_D' 来使用搜索字段查找纹理资源。

  7. 对其他 纹理样本节点(Texture Sample Node) 重复步骤6,确保选择名为 T_Rock_04_n 的法线图纹理。

    newBothTexturesSelected.png

    材质图表应该类似于上图。

  8. T_Rock_04_D 纹理样本的 颜色引脚(白色) 连接到岩石材料的 基础颜色引脚

    newConnectColorPin.png

    新连接的 白色引脚 包含纹理的颜色通道。

  9. T_Rock_04_n 纹理样本的 法线引脚(白色) 连接到岩石材质的 法线引脚

    newConnectNormalPin.png

    新连接的 白色引脚 包含纹理的法线贴图的信息。

  10. 预览(Preview) 应类似于下图。

    newPreview_DN.png

  11. 按住 “1” 键并在 图表面板(Graph Panel) 中左键单击以创建三个(3常量(Constant) 节点。

    Constants.jpg

    常量节点 是可修改的标量浮点变量。*

  12. 按住 “3” 键,在图表面板中左键单击以创建一个(1Constant3Vector

    Constant3.jpg

    Constant3Vector 节点是与颜色对应的可修改向量,没有alpha通道。*

    如果想要了解有关处理常量表达式的更多信息,请阅读我们的常量表达式文档。

  13. 您的节点应该进行安排,以便轻松进行连接,避免导线交叉或相互滑动。

    newMatConstantsAdded.png

  14. 将所有 常量(Constant)Constant3Vector 节点连接到 “岩石”材质主节点 中的对应引脚。

    newAllNodesConnectedNoVal.png

  15. 通过更新 详细信息(Details) 面板中的 值(Value) 参数,更改每个 常量(Constant)Constant3Vector 的值。

    • 高光值(Specular Value) = 0.0

    • 粗糙度值(Roughness Value) = 0.8

    • 不透明度值(Opacity Value) = 0.95

    • 次表面颜色(Subsurface Color) = 红色(1,0,0)

    newAllConnectedAllAdjusted.png

  16. 预览(Preview) 应类似于下图。

    newPreviewAll.png

    请确保在退出 材质编辑器(Material Editor) 之前保存您的材质。

您就快大功告成了!您刚刚使用 材质编辑器(Material Editor) 编辑了 “岩石”材质

要找到所有材质编辑器键盘快捷键的列表,转到 编辑菜单(Edit Menu)> 编辑器首选项(Editor Preferences)> 键盘快捷键(Keyboard Shortcuts)>“材质编辑器”和“材质编辑器生成的节点)” 类别。

8. 将材质应用于静态网格体Actor

现在,您已经准备好将一切组合在一起!

这一步的目标是将我们的 材质(Material) 应用到我们导入的静态网格体中。具体来说,您将学习如何:

设置Actor的默认材质

本节将向您展示如何设置 静态网格体Actor的 默认材质。每当您在关卡中放置一个 Actor 时,都将使用默认材质。

  1. 内容浏览器(Content Browser) 中,双击您在本指南中早先导入的资源。

    newBrowserContenAsset.png

    静态网格体编辑器将加载您的资源以供编辑。

    StaticMeshEditor.jpg

  2. 详细信息(Details) 面板的 LOD0 下,单击材质的下拉菜单。

    LOD0.png

  3. 选择您早先创建的 “岩石”材质。该材质将出现在选择窗口中。

    selectRockMaterial.png

    您的 预览窗格(Preview Pane) 将更新以反映新应用的材质。

    NewDefaultMaterial.jpg

  4. 先单击 保存(Save) 按钮,然后关闭 材质编辑器(Material Editor)

  5. 内容浏览器(Content Browser) 中,将新制作的 静态网格体Actor(Static Mesh Actor) 拖动到关卡中。

    newMaterialInLevel.png

    当您将该资源放到关卡中时,将使用指定的 材质

更改Actor使用的材质

当我们将 静态网格体 对象放入关卡时,便创建了一个对象实例(Actor)。对于该 Actor 的每个实例,我们都可指定其 材质(Material)

以下介绍如何更改静态网格体Actor的材质。

  1. 选择您的 静态网格体Actor(Static Mesh Actor)

    newStatisMeshSelected.png

  2. 详细信息(Details) 面板中,找到 材质(Materials) 部分,并单击 材质(Materials) 下拉菜单。

    materialDropDown.png

  3. 在弹出菜单中,选择不同的材质。

    selectTutorialAssetMat.png

  4. 或者,将新材质拖放到 静态网格体Actor(Static Mesh Actor) 上。

    newMaterialDrop.png

您刚刚通过以下方式将材质应用到您的静态网格体Actor:

  • 设置Actor的默认材质

  • 更改Actor使用的材质

现在,我们即将学完《美术师快速入门指南》。到目前为止,您应该掌握了以下操作所需的技能:

✓ 设置项目
✓ 创建材质
✓ 编辑材质
✓ 将材质应用于静态网格体Actor

您准备好独立地做一些练习了吗?

9. 看你的了!

利用所学知识,创建一个与以下图表类似的新 材质

PlasticMaterialNetwork.png

Main Material节点设置模拟塑料材质。

Basic_Asset1 添加到关卡,对其应用材质,并应用“砖块”法线贴图纹理更新材质。

NormalMapAdded.jpg

有关本快速入门指南所包含主题的更多信息,请参阅虚幻编辑器手册

有关导入不同类型内容的更多信息,请参阅:

有关本快速入门指南包含的详细内容,请参阅:

Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见