硬件和软件规格

用虚幻引擎开发游戏时最低和推荐硬件规格和必要的软件

Windows
MacOS
Linux

虚幻引擎对运行编辑器有部分特殊硬软件要求。本页将对此类要求及虚幻引擎安装程序中必备条件安装程序将安装内容进行讲解。

推荐硬件

操作系统

Windows 10 64位

处理器

Intel四核处理器或AMD,2.5 GHz或更快

存储器

8 GB RAM

显卡/DirectX版本

DirectX 11或12 兼容显卡

操作系统

macOS 10.14 Mojave

处理器

Intel四核处理器, 2.5 GHz或更快

存储器

8 GB RAM

显卡

Metal 1.2兼容显卡

操作系统

Ubuntu 18.04

处理器

Intel四核处理器或AMD,2.5 GHz或更快

存储器

32 GB RAM

显示卡

NVIDIA GeForce 960 GTX或使用NVIDIA最新二进制驱动程序的更好型号

最低软件要求

运行引擎或编辑器的最低配置要求如下。

运行引擎

操作系统

Windows 7

DirectX Runtime

DirectX End-User Runtimes(2010年6月)

运行引擎

操作系统

macOS 10.14 Mojave

运行引擎

操作系统

任何CentOS 7.x及以上的可支持Linux新发行本版

Linux内核版本

内核3.x或更新版本

附加依赖项

glibc 2.17或更新版本

使用引擎开发游戏的程序员配置要求如下。

用引擎开发

“运行引擎”的所有要求项(自动安装)

Visual Studio版本

  • Visual Studio 2017 v15.6或以上(推荐)

  • Visual Studio 2019

当前版本的UE4不再支持Visual Studio 2015。如果正在使用当前版本的UE4进行开发,请使用VS 2017或VS 2019。

iOS应用程序开发

iTunes版本

iTunes 11或以上

用引擎开发

Xcode版本

9.4

用引擎开发

操作系统

Ubuntu 18.04

编译程序

clang 6.0.1

可选

IDE

Visual Studio Code, CLion, QtCreator

必备条件安装程序安装的软件

虚幻引擎包括必备条件安装程序,其负责安装运行编辑器和引擎所需的一切,包括多个DirectX组件和Visual C++ Redists。在通过Epic Games启动程序安装虚幻引擎时,启动程序会自动安装这些必备条件。如果你是从源代码编译的虚幻引擎,或是出于特殊需要,要准备一台安装虚幻引擎必备条件的计算机——比如你要设置一台作为群代理 的全新计算机,可则以自行运行必备条件安装程序。

你可以在虚幻引擎安装目录的 Engine/Extras/Redist/en-us 文件夹中找到适用于32位和64位Windows系统的独立可执行文件。

如果你使用Perforce来获取虚幻引擎源代码,也可以在Perforce元库的同一个文件夹 Engine/Extras/Redist/en-us 中找到预先编译的二进制文件。安装程序的源文件在 Engine/Source/Programs/PrereqInstaller 下。

下表列出了必备条件安装程序所安装的软件。

DirectX组件

Visual C++ Redists

XInput 1.3(2007年4月)

Visual C++ 2010 CRT

X3DAudio 1.7(2010年2月)

Visual C++ 2010 OpenMP库

XAudio 2.7(2010年6月)

Visual C++ 2012 CRT

D3D Compiler 4.3(2010年6月)

Visual C++ 2013 CRT

D3DCSX 4.3(2010年6月)

Visual C++ 2015 CRT

D3DX9 4.3 (2010年6月)

D3DX10 4.3 (2010年6月)

D3DX11 4.3 (2010年6月)

列表中最重要的DirectX组件为XInput、X3DAudio和XAudio依赖项。DirectX的标准安装程序不包含此类依赖项(默认不与Windows一起发布),因此必须进行手动安装,或使用应用程序进行发布。

显卡驱动

目前推荐使用各显卡生产商发布的最新稳定版本:

性能说明

本列表显示的是Epic采用的典型配置,使用虚幻引擎4的游戏开发者可以此为参考:

  • 64位Windows 10系统

  • 64 GB RAM

  • 256 GB SSD(系统盘)

  • 2 TB SSD(数据驱动)

  • NVIDIA GeForce GTX 970

  • Xoreax Incredibuild(开发工具包)

  • Xeon六核E5-2643 @ 3.4GHz

若无发获取Xoreax Incredibuild(开发工具包),建议使用12核至16核处理器的机器进行编译;推荐阅读硬件基准测试程序(2017)参考,了解是否使用XGE进行编译的更多信息。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback