ARKit先决条件

使用苹果ARKit进行增强现实开发的先决条件与步骤。

Windows
MacOS
Linux
本页面的内容

虚幻引擎本就支持iOS设备。如果您已经在使用虚幻引擎和iOS设备,您不需要任何额外配置就可以开始使用增强现实和虚幻引擎。

常规先决条件

虚幻引擎和iOS设备的基本配置详见虚幻引擎文档的iOS游戏开发部分。

从虚幻引擎4.23.1起,所有ARKit版本都需要Xcode 11或更高版本。

ARKit 1.5先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 已安装虚幻引擎4.20或更高版本。

  • 已安装Xcode 9或更高版本。

  • 一台受支持、已配置并已连接的手持式iOS设备。

ARKit 2.0先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 已安装虚幻引擎4.20或更高版本。

  • 已安装Xcode 10或更高版本。

  • 一台受支持、已配置并已连接的手持式iOS设备。

ARKit 3.0先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 已安装虚幻引擎4.23.1或更高版本。

  • 已安装Xcode 11或更高版本。

  • 一台受支持、已配置并已连接的手持式iOS设备 device.

只有安装了iOS 13、A12/A12X(或更高版本)放生芯片、Apple Neural Engine(ANE)以及原深感摄像头的设备才支持ARKit 3.0,如iPhone XS、iPhone XS Max、iPhone XR以及11英寸和12.9英寸的2018 iPad Pros。

标签
Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见