原生工具链

Windows
MacOS
Linux
本页面的内容

自虚幻引擎4.20版本起,我们的设置shell脚本(Setup.sh)会自动下载一个原生工具链,这保证编译器和连接器能够使用我们的基本代码。使用原生工具链,您可以针对一个固定的sysroot(至少是glibc)进行编译,因此,例如当您在Ubuntu 18.04上编译一个游戏时,您将能够在CentOS 7上启动二进制文件。

获取工具链

请使用下表以下载相应的工具链:

UE4 版本

工具链

4.22

-v13 基于clang 7.0.1

4.21

-v12 基于clang 6.0.1

4.20

-v11 基于clang 5.0.0

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见