设置虚幻引擎的Visual Studio

设置Visual Studio以使用虚幻引擎4的提示、技巧和技术。

Windows
MacOS
Linux

虚幻引擎(简称UE)能与Visual Studio(简称VS)完美结合,使你能够快速、简单地改写项目代码,并能即刻查看编译结果。设置Visual Studio以使用虚幻引擎能提高开发者对虚幻引擎的利用效率和整体用户体验。

在本文中,我们将讲解从虚幻引擎设置方法到Visual Studio工作流在内的诸多基础知识。尽管本文主要聚焦于最新版本的UE和VS,你可以查看我们的Visual Studio历史版本参考指南,了解如何使用UE和VS。

设置虚幻引擎到Visual Studio工作流前

下列表格列出了已集成二进制版虚幻引擎的Visual Studio版本。

虚幻引擎版本

Visual Studio版本

4.25或更高版本

VS 2019 (Default)

4.22或更高版本

VS 2017

4.15或更高版本

VS 2017

4.10 - 4.14

VS 2015

4.2 - 4.9

VS 2013

运行虚幻引擎必备条件安装程序

在Epic启动器安装或从GitHub复制虚幻引擎时,将自动运行虚幻引擎必备条件安装程序。若通过Perforce进行安装或同步虚幻引擎,则需要手动运行必备条件安装程序。运行本地编译的虚幻引擎工具前必须进行此操作。安装程序位于 [UE4RootLocation]\Engine\Extras\Redist\en-us]

新安装Visual Studio时的选项

如果你是初次安装Visual Studio,请确保启用下列选项。

C++工具

要在安装Visual Studio时添加C++工具,请确保在 工作量(Workloads) 下选择 用C++开发游戏(Game development with C++)

  • C++ profiling tools

  • C++ AddressSanitizer (optional)

  • Windows 10 SDK (10.0.18362 or Newer)

包含UE4安装程序

要在安装Visual Studio时包含UE4安装程序,在右侧的 摘要(Summary) 工具栏中展开 用C++开发游戏(Game development with C++),并勾选 可选(Optional) 下的 虚幻引擎安装程序(Unreal Engine installer)

VS2017_SettingsInstaller.png

推荐设置

以下是使用Visual Studio和虚幻引擎4的开发者的推荐设置。

假如你觉得我们的VS看上去有些陌生,那是因为我们把主题改成了黑色调。方法是,打开 工具(Tools) > 选项(Options) > 环境(Environment) > 常规(General) > 颜色主题(Color theme)。

增加解决方案配置下拉菜单的宽度

  1. 右键点击工具栏,选择弹出菜单底部的 自定义(Customize)
    SelectingCustomize.png

  2. 单击 命令(Commands) 选项卡并选择 工具栏(Toolbar) 单选按钮。
    SelectToolbarRadioButton.png

  3. 工具栏(Toolbar) 旁边的下拉菜单中,选择 标准(Standard)
    SelectStandard.png

  4. 预览(Preview) 列表中,选择 解决方案配置(Solution Configurations) 功能按钮(你可能需要向下滚动),然后点击右侧的 修改选项(Modify Selection)

    ![](SelectModifySelection.png)

  5. 宽度(Width) 设置为 200。然后单击 OK
    SetWidth_200.png

  6. 单击 关闭。你的工具栏应该会立刻更新。

添加解决方案平台下拉菜单

1.找到 标准(Standard) 工具栏最右策的按钮(若将光标悬停在此处,将显示 标准工具栏选项(Standard Toolbar Options))。

![](SetUpVisualStudio-RecommendSettings-SolutionPlatformsStep01.png)

1.单击下拉按钮,单击 添加或移除按钮(Add or Remove Buttons),然后单击 解决方案平台(Solution Platforms),将菜单添加到工具栏中(此步骤可能已经默认完成)。

![](SetUpVisualStudio-RecommendSettings-SolutionPlatformsStep02.png)

关闭错误列表窗口

通常情况下,若代码出错,会自动弹出**错误列表(Error List)。但使用虚幻引擎时,错误列表(Error List) 窗口会误报错误信息。建议在使用虚幻引擎时,禁用 错误列表(Error List) 窗口,并使用 输出(Output) 窗口查看实际代码错误。以下是关闭 错误列表(Error List)** 窗口的步骤。

  1. 若已打开 错误列表(Error List) 窗口,先请关闭。

  2. 工具(Tools) 菜单中打开 选项(Options) 对话框。
    SetUpVisualStudio-RecommendSettings-ErrorListOffStep02.png

  3. 选择 项目和解决方案(Projects and Solutions),取消勾选 编译出错时始终显示错误列表
    SetUpVisualStudio-RecommendSettings-ErrorListOffStep03.png

  4. 单击 OK

以下是其他一些可能有用的配置设置:

  • 关闭 显示非活跃代码块(Show Inactive Blocks)。如不关闭,文本编辑器中的很多代码块将变灰。前往 工具 > 选项 > 文本编辑器 > C/C++ > 视图) 关闭此设置

  • 设置 禁用外部依赖性文件夹 为True,以在 解决方案浏览器(Solution Explorer) 中隐藏不必要的文件夹。在 工具 > 选项 > 文本编辑器 > C/C++ > 高级 中找到 禁用外部依赖项性文件夹

  • 关闭 编辑并继续(Edit & Continue) 功能,无需使用。前往 工具 > 选项 > 调试(Debugging) > 编辑并继续(Edit and Continue)

  • 打开IntelliSense。参见本页Intellisense、实时错误和筛选 部分。

调试

有关调试支持的更多信息,请查阅我们的Visual Studio历史信息主页的调试部分。

标签
Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见