从VRED导出Datasmith内容

描述如何安装Autodesk VRED的导出器插件脚本,以及如何将VRED场景导出为FBX文件,并使用Datasmith将其导入虚幻。

Windows
MacOS
Linux

安装导出器插件脚本

需要先安装VRED插件脚本,然后才能开始在虚幻引擎中使用VRED内容。

要了解导出器插件当前支持哪些版本的VRED Professional,请参阅Datasmith支持的软件和文件类型

请按照以下步骤为计算机上安装的任何受支持的VRED版本安装Datasmith导出器插件脚本。

  1. 在虚幻引擎安装文件夹中,找到在 Studio/\Plugins\Editor\DatasmithFBXImporter\Extras\VREDPlugin 文件夹中的 vrDatasmithExporter.py 脚本。

  2. 复制此文件夹及其中所有内容到VRED搜索插件的位置。
    例如,在Windows平台,该位置可能是 C:\Users\<username>\Documents\Autodesk\VRED-<internalVersion>\ScriptPlugins,其中 <username> 是Windows用户ID,而 <InternalVersion> 表示安装的VRED版本。
    关于寻找此路径的完整细节,请参阅VRED文档

    VRED终端窗口也可以帮助寻找此路径。在主菜单中选择 查看(View)> 终端(Terminal) 打开终端,然后寻找以 Looking for script plugins in 开头的行。例如:
    vred-terminal.png

  3. 重启VRED。

导出到Datasmith

在以希望的方式设置好VRED场景并注册好变体之后,将场景导出为FBX:

  1. 在VRED主菜单中,选择:

    • 文件(File) > 导出(Export) > 导出到Datasmith..(Export to Datasmith...)(适用于VRED 2018)

    • 文件(File) > 导出场景数据(Export Scene Data) > 导出到Datasmith..(Export to Datasmith...)(适用于VRED 2019)
      在VRED中进行的Datasmith导出

  2. 浏览至文件夹并选择文件名。

导出器将在所选择的位置创建 .FBX 文件。

最终结果

现在你可以尝试将新的 .FBX 文件导入到虚幻编辑器中。请参阅将Datasmith内容导入虚幻引擎4

除了 .FBX 文件以外,导出器还会创建附加文件:包含有关场景中的光源的额外信息的 .lights 文件和包含有关注册的变体的信息的 .var 文件。这些文件中包含Datasmith导入程序所需的信息。如果将 .FBX 文件移到新位置,请确保将这些附加文件放在相同的相对路径中。

Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见