Unreal Studio用户入门

帮助新Unreal Studio用户熟悉虚幻引擎4的指南。

Windows
MacOS
Linux

本指南对虚幻引擎4(UE4)进行概述,旨在帮助Unreal Studios用户利用现有体验快速熟悉虚幻引擎4。本页中的信息将介绍虚幻编辑器及其工具的公共区域、能够协助用户顺利适应UE4工具的现有文档,及最适合引擎实时开发的工作流等。

作为Unreal Studio产品的一部分,Datasmith是用于将离线渲染应用程序中创建的场景和资源导入实时引擎的系列工具和插件。无论是首次使用Datasmith或已有使用经验,此页面中的信息都可帮助Unreal Studio用户在使用实时引擎时优化工作流。即使目前未使用Datasmith,此处引用的最佳实例和建议也可向使用UE4的企业用户提供帮助。

创建虚幻引擎4项目

若要创建虚幻引擎4项目,需在安装并启动引擎时使用项目浏览器进行操作。。利用项目浏览器可选择现有项目或者新建蓝图、C++或Unreal Studio项目。在 新建项目(New Project) 选项卡中,选择新项目的基础模板:

ProjectBrowser_MyProject.png

若已设置并激活Unreal Studio的权限,将自动准备此类模板中创建的项目,以便与Unreal Studio产品所属插件一并使用(如Datasmith)。

Unreal Studio 选项卡含有仅Unreal Studio用户可用的模板:

image_1.png

Unreal Studio目前提供三种模板:

  • 空白 - 干净的空白项目,未添加任何额外内容。

  • 产品查看器 - 可使用该模板通过预编译交互和导航查看单独资源,以显示对象。

  • 多用户查看器 - 便于审查多用户设计的模板,尤其适用于架构项目。

欲了解Unreal Studio模板的更多相关信息,参见Unreal Studio项目模板页面。

若无法看到Unreal Studio选项卡,可能是是尚未激活Unreal Studio权限,或此类权限出现问题。但无需担心。可在 蓝图(Blueprint)C++ 选项卡中创建项目,之后再将其转换为Unreal Studio项目。要了解将现有项目或之前创建的非Unreal Studio项目转换为Unreal Studio项目,参见设置虚幻项目使用Datasmith

编辑器

目前多数用户都在使用Autodesk 3ds Max,因此选择其进行界面比较。

下方为Autodesk 3ds Max和虚幻编辑器对比图,彩色颜色编码表示常用功能。每个区域都进行了标记以显示对等的虚幻引擎4术语。虚幻编辑器的布局可完全自定义,可在编辑器中自由拖放任意选项卡。

单击图像查看完整尺寸。

单击图像查看完整尺寸。

1

放置面板

创建面板

2

主工具栏

主工具栏

3

世界大纲视图

场景浏览器

4

详情面板

命令面板

5

视口

视口

6

内容浏览器

编辑资源

在Autodesk 3ds Max中,命令面板公开所选对象的属性。在虚幻引擎4中,细节(Details) 面板公开所选对象的属性,而较大的编辑任务需要用到有专属窗口或选项卡的专用编辑器。打开纹理、材质或静态网格体时可找到此类范例。将打开所有已编辑资源的新选项卡窗口,类似于web浏览器。

image alt text

材质编辑器停靠在主虚幻编辑器选项卡中。

停靠编辑器窗口时,可选择相应选项卡将其显示在前景,而选择其他选项卡时会将其移到后台(如之前范例所示)。除主编辑器选项卡外,所有选项卡都可作为独立窗口拖动,或者与编辑器内其他独立窗口或选项卡停靠在一起。

主工具栏

与多数应用程序中的相同,主工具栏(或关卡编辑器工具栏)是一组用于快速访问常用工具和操作的命令。

image alt text

场景导航

利用虚幻引擎4的部分方法,可导航场景、选择和操纵Actor,而另一些方法可用于改变内容在视口中的显示方式(即使是在虚拟现实(VR)中操作)。

使用鼠标和键盘的 台式机 用户可参见视口功能按钮页面,了解用于导航视口场景的功能按钮。在该页面中,可学习虚幻引擎4中用于选择和转换Actor、平移、环绕和缩放相机以及导航的功能按钮。

使用 虚拟现实(VR) 和控制器的用户可参见VR模式功能按钮以VR模式浏览场景页面,了解可用功能按钮。还可了解如何使用此类按钮抓取对象进行操纵,在场景中四处移动,在场景中自我缩放来实现与场景可视化真实世界比例类似的效果。

快速术语表

以下部分包含Enterprise或Autodesk 3ds Max的常见术语及其虚幻引擎4同等术语(或大致同等术语)。点击虚幻引擎4关键字,可直接导航到虚幻引擎4文档,其中包含更多信息。

类别

Autodesk 3ds Max

UE4

说明

网格体

网格体或网格体对象

静态网格体

设置和蒙皮网格体

骨架网格体

对象/节点

关卡Actor

修饰符堆栈结果/基础对象

静态网格体

编辑器UI

场景浏览器

世界大纲视图

修改面板

细节面板

图层面板

图层面板

资源浏览器工具

内容浏览器

视口

视口

材质

材质

材质

使用实例化纹理的材质

材质实例

材质编辑器

材质编辑器

效果

粒子系统

效果、粒子系统、级联

粒子视图

级联

动画

两足动物动画

骨架动画系统

此类动画并不完全相同,但可作为进行对比的良好资源,以查看虚幻使用导入动画的方法。

顶点子对象级动画

顶点动画

无用于将顶点动画应用到资源的专属工具,但可使用该Autodesk 3ds Max工具将此类动画导入UE4并使用材质编辑器进行应用。

编程

MAXScript

Python

MAXScript脚本

蓝图

物理

线条追踪,形状追踪

MassFX

碰撞,物理

光源

定向光源

定向光源

点光源

点光源

聚光源

聚光源

天空光照

天空光照

光源门户

Lightmass门户,Lightmass重要体积

光度光源

IES描述文件,物理光源单位

后期处理

环境曝光控制,相机曝光控制

后期处理体积

渲染

全局照明

Lightmass

过场动画

轨迹视图

序列编辑器

纹理

UV贴图通道

静态/骨架网格体的UV通道

虚幻引擎架构

关卡(贴图)

所有场景文件都为自含式,而在虚幻引擎4中,多个关卡(或场景)可进行单独打开,或组合到虚幻编辑器中。

项目和文件

此类目录和文件有哪些?

对于在企业空间中创建的项目,需维护文件夹来管理构成场景项目文件的纹理和网格体的源文件。在虚幻中,项目固定储存于自身目录中,并拥有引用指定版本虚幻引擎编辑器的项目文件,此类项目文件还会查看用于存储项目内容的一组文件夹。

image alt text

范例:虚幻中的内容浏览器和Windows资源管理器中维持的文件夹结构。

要打开项目,可使用Epic Games Launcher搜索项目的

image alt text

或者,在Windows中导航到项目文件夹,双击 .uproject 文件以在虚幻编辑器中加载项目。

image alt text

项目文件夹包含多个子文件夹,其中包含项目内容、源代码以及部署到多平台时所用的配置文件和二进制文件。其中最重要的是 ContentSource 文件夹;前者包含可在内容浏览器中引用和打开的所有资源;后者包含使用源版本引擎时创建的C++文件或编辑内容。

资源存放位置

在虚幻引擎4中,所有项目均有 Content 文件夹,其与打开虚幻编辑器时的内容浏览器相同。这是存储所有项目资源的地方。

单击图像查看完整尺寸。

文件夹中的资源为 .uasset 文件。此类文件是导入受支持文件类型时虚幻创建的文件。已无需源文件来维护导入到虚幻中的资源,但建议保存这类文件,以防需要编辑时进行使用。

不建议在虚幻编辑器外部对项目“Content”文件夹中的资源进行重新组织。此操作可能会破坏内容,甚至损坏项目。如此移动内容会破坏虚幻编辑器中对资源的引用。例如,利用项目的Windows文件夹移动纹理资源时,将遗失引用该纹理的材质,意味着分配至关卡静态网格体的此类材质无法正确显示。

确保移动资源时使用虚幻编辑器,可保持引用且不会破坏内容。

将资源导入虚幻引擎4

有两种方法可将资源导入项目:

1.使用Datasmith导入虚幻Datasmith和支持CAD文件类型。

2.使用内容浏览器导入与Datasmith无关联的支持资源类型。

使用上述任一方法导入资源时,其都会存储在镜像Windows中项目文件夹结构的内容浏览器中。使用内容浏览器打开资源,并利用内容浏览器在资源自身编辑器中编辑资源。进行的编辑会实时自动更新编辑器和关卡中的资源(若在其中进行引用)。

image alt text

如导入内容不属于Datasmith的一部分,资源会直接导入到Content文件夹下,指定文件夹位置时除外。作为Datasmith导入进程的一部分,将在以虚幻Datasmith或CAD文件名称命名的自身文件夹下创建Datasmith资源。

支持的常见文件格式

其他软件应用程序支持广泛的文件格式。虚幻引擎4原生支持最多常见文件类型。

原生资源类型

支持格式

3D

.fbx、.obj、.abc、.srt

纹理

.png、.jpeg、.jpg、.bmp、.tga、.dds、.exr、.psd、.hdr、.ies、.float、.pcx

声音

.wav、.wave、.wmv、.caf、.aif、.aiff、.au、.adts、.as、.ac3、.amr、.bwf、.cdda、.acc、.mp3、.snd

字体

.ttf、.otf

视频

.mov、.mp4、.m4v、.m4a、.wmv、.avi、.asf、.3gp、.3g2、.sdv

利用如虚幻引擎4的Datasmith等插件,可添加对更多文件类型的支持。欲了解支持文件类型的综合列表,参见Datasmith支持的软件和文件类型页面。

场景的存储方式

在软件应用程序中,构成场景的资源会构成场景文件。虚幻使用不同的概念,即所谓的“关卡”或“贴图”文件。此类文件是独立的“场景”,其中放置了自身资源。其可单独打开,甚至进行组合以将较大关卡拆分为多个较小关卡。贴图文件存储关卡及其所含对象的数据和部分关卡指定的设置。

欲进一步了解关卡和虚幻编辑器使用和存储此类文件的方式,参见使用关卡资源页面。

更改编辑器和项目设置的方法

可在主菜单的 编辑(Edit)> 编辑器首选项(Editor Preferences)项目设置(Project Settings) 中进行此类设置。与软件应用程序中的首选项或设置类似,进行此类设置可自定义和更改项目工作方式的某些部分。

在虚幻引擎4中,利用编辑器首选项中的部分设置,可通过常见色盲缺陷颜色校正、启用编辑器中的实验功能、将度量单位从厘米更改为较熟悉单位等设置,更改编辑器工作方式。

利用项目设置 可指定项目相关信息(如项目命名和图标)、配置游戏输入绑定、以及定义运行项目时引擎的行为。

自动加载上一项目的方法

打开软件应用程序的场景文件时,可立即访问该场景的内容。但在虚幻引擎4中,在Epic Games Launcher中打开编辑器时,会导航至虚幻项目浏览器,可在其中选择项目(若已创建)。要实现以上设置,请执行以下操作:

在项目浏览器中,选择要打开的项目时,启用 启动时固定加载上一项目(Always load last project on Startup)

单击图像查看完整尺寸。

项目输入绑定的设置位置

在虚幻引擎4中,可添加各种按钮(操作)和模拟功能按钮(轴),以在触发输入事件时回调游戏角色(Pawn)。输入绑定位于 输入(Input) 部分下的 项目设置(Project Settings) 中。在此将给定各功能按钮的命名与键盘按键或控制器按钮的默认绑定。在蓝图中按下按键时,此类输入绑定命名可用于执行操作,利用其还可将多个输入设为单个命名。例如,若想将玩家角色在关卡中向前移动,可调用输入绑定“Forward”,然后将键盘上的“W”键和控制器操纵杆上的“上”位置与该“Forward”事件绑定。

欲了解更多详情,参见输入页面。

更改项目初始场景的方法

项目设置(Project Settings) 可更改项目的起始地图。在主菜单中选择 编辑> 项目设置,然后在 地图和模式(Maps & Modes) 下将 编辑器启动地图(Editor Startup Map) 更改为内容浏览器中要使用的内容。

单击图像查看完整尺寸。

运行游戏的方法

最简单的运行游戏方法是单击主工具栏上的 运行(Play) 按钮。此操作将在编辑器视口中以所有功能和当前所想游戏模式运行游戏。若要以standalone应用程序运行,单击 运行(Play) 旁的下拉菜单,选择 standalone游戏。最后,若要在移动设备或web浏览器中运行,使用工具栏上的启动(Launch)按钮,并选择可用平台。某些平台需要进行额外设置,并且在安装所需必备条件后才能使用。

FAQ_Play-1.png

欲了解各种支持平台的额外信息,参见平台开发页面。

虚幻引擎4中使用的单位

在软件应用程序中,可在首选项或设置中调整主计量单位。在UE4中,主计量单位是1厘米。因此,建议更改主计量单位与虚幻中所用单位匹配。

坐标系是什么?哪个方向是朝上的?

虚幻引擎4使用左旋坐标系。在虚幻引擎4中,正X为“前”,正Y为“右”,正Z为“上”。

查看项目日志输出的方法

,要在编辑器中打开 输出日志(Output Log),可使用文件菜单选择 窗口(Window)>开发者工具(Developer Tools)

FAQ_OutputLogWindow.png

美术源自动重导入

目前建议使用Datasmith时,不工作流程中使用自动重导入。但是,对于创建和导入的原生支持资源,可设置自动重导入监控。

在项目中,除使用Datasmith插件导入的内容外,若还将使用其他内容,可设置虚幻以使用自动重导入。其可监控存储如FBX、OBJ、PSD、纹理、音频和UE4支持导入的其他原生文件等资源的源资源文件夹。更新源资源时,受监控的文件夹将自动重导入文件,并反应引擎中的变化。Datasmith则不同,此类资源未直接放置在关卡中,其会尝试在编辑器中获取内容,而非设置内容。

从对象到Actor

对象位置

在Autodesk 3ds Max等软件应用程序中,场景内的资源可能被统称为场景实体、几何体对象或其他熟悉构成场景的对象术语。在UE4中,等效的术语是Actor。Actor是添加到关卡的对象,会引用静态网格体和材质等其他资源。

可使用空Actor(如视频中的Actor)构建项目,而UE4同时也包含一些有内置功能的特殊类型Actor,如Pawn(指代玩家或人工智能(AI)对象)、指数高度雾体积或光源。可自定义关卡中此类Actor的属性,甚至可使用其细节面板向其添加额外组件。此操作同样适用于内容浏览器中从Actor、材质或蓝图处引用的资源。也可以设置其属性并向其添加组件。

所有内容是否都是Actor?

不是。Actor 是UE4中最常用的gameplay类,也是唯一可在关卡中生成的类型。因此,放置在关卡的内容都是Actor。

另外一个重要类型是 对象(Object)。Object是所有虚幻类的基类,包括Actor和许多其他类。其是比Actor级别更低的构造函数,但仍具有虚幻类的部分功能,如反射或序列化。Object是需要定义与Actor模型不匹配的新类型时所使用的类。例如,Actor组件 是所有组件的基类,其从Object派生而来,而非Actor。

因此无需担心此函数有何用处,其可帮助澄清Actor和Object会接连出现或用Object代替Actor的原因。

组件的位置

在Autodesk 3ds Max等软件应用程序中,可使用修饰符堆栈向对象添加功能或扩展属性。

在UE4中,组件是可以添加到关卡或蓝图Actor的功能。此类组件无法独自存在,但是添加到Actor后便可访问和使用组件所带功能。可将其视为创建迷你场景或构成单个对象的一组Actor的方法。利用此进程可在虚幻中易于掌控的方式灵活地控制场景。

例如,若有一个火炉资源,可添加各式组件来构成该基本资源的其他部分,如门、底层抽屉和光源。

可向Actor添加许多不同类型的组件,此类Acotor对如静态网格体、粒子系统、光源等进行引用。要向Actor添加组件,使用 细节(Details) 面板并从列表中选择要添加的组件。

在该范例中,场景中放置的空Actor已添加静态网格体、点光源和粒子系统组件。该Actor仅存在于该关卡,若转换为蓝图Actor,则可作为单个资源存在于内容浏览器中。

欲了解更多详情,参见组件页面。

传统光线追踪渲染与实时渲染

虚幻引擎4中的光照系统设计灵活,可提供与项目匹配的各级光照功能和实时游戏引擎。意味着可在场景中使用完全静态(或预烘焙)光照或完全动态的光照。对于企业建筑视觉用途,将使用静态光照,并利用UE4中的Lightmass全局照明系统。

Datasmith_HFB.jpg

图片由HFB Visuals提供。

为充分利用UE4光照系统,下文将介绍了几项概念,以帮助用户构建关卡光照,并轻松提高质量。首先请记住,需在所有更改完成后构建光照以查看最终结果。此外,阴影信息存储在光照贴图纹理中,需提高该纹理分辨率来采集精美细节。

构建关卡光照及其意义

在虚幻中,尤其使用企业架构时,核心内容便是打造与软件应用程序中的渲染器匹配的精美照明场景。虚幻Lightmass全局照明系统用于生成关卡光照。在此之前,需生成合适的资源光照贴图UV,以正确存储该光照和阴影信息。虚幻引擎4负责创建光照贴图时的大量工作,其会在导入时自动生成光照贴图。这样便不会出现重叠面,且会将UV图正确打包到UV的0,1空间中。对于虚幻工作室用户,Datasmith会在导入时展开网格体的UV,然后再重新打包,从而进一步简化该进程。原生版UE4仅会重新打包现有UV,因此该操作可减少问题的发生。之后的光照贴图UV章节将详细说明该过程。

导入Datasmith场景时,其将直接导入到关卡中,并按照应用程序场景文件中的方式放置光源。可在此处查看“预览”光照,能大致了解场景的效果。

PreviewLighting.png

阴影区域出现“预览”标签时,这代表以下几项目含义。第一,正在使用静态或禁止光照源,因此使用中的光源要求构建关卡光照。第二,所示阴影使用的是动态阴影,便于了解构建光照时的效果。出现这种情况时,无法获得GI反射的精确光照或完全精确的关卡阴影。

要开始构建光照,可单击主工具栏中的 构建(Build) 按钮。

BuildButton.png

构建(Build) 按钮将开始一系列任务,如重新构建光照,重新采集反射采集Actor的反射和游戏其他相关任务。对于Unreal Studio用户,须进行关卡光照质量设置。该设置位于构建(Build)下拉菜单中,然后选择 光照质量(Lighting Quality)

BuildLighting.png

光照质量(Lighting Quality) 包含 预览(Preview)产品(Production) 等级别。质量级别决定了生成关卡光照时光照的精确度。对于多数场景而言,“预览(Preview)”构建时间更短,但精确度较低。“产品(Production)”质量的构建时间更长,但精确度更高,并可代表关卡设置的最终光照构建。

欲了解各质量级别的对比信息,请访问光照故障排除指南上,由社区创建和维护的光照质量比较范例。

构建光照时,屏幕角落会弹出百分比窗口,其表示当前正在构建关卡光照。若百分比卡住,请耐心等待光照的生成。根据项目复杂程度和所选光照级别,生成光照可能需要一段时间才能完成。

BuildLighting1-1.jpg

光照构建完成并应用于场景后,“预览(preview)”标签将消失。但生成的阴影质量或许不如预期。请牢记:关卡中设置的光照质量仅影响虚幻Lightmass的精确度,而非采集光照贴图UV阴影信息的纹理分辨率数量。因此,请阅读下一章节,其中将讨论光照贴图UV的重要性以及控制其分辨率的方法。

BuiltLighting.png

光照贴图UV

在导入期间,将根据UV通道自动生成每个静态网格体的光照贴图UV。UE4将默认使用通道0来生成光照贴图UV。如前所述,对于虚幻工作室用户,Datasmith可一次性完成解包并重新打包的进程,这样便不会有重叠面且所有UV图都包含在0,1 UV空间中,从而进一步简化该这个进程。无法访问UV编辑器来进行正确展开,或只是想将场景导入到UE4中时,如CAD等应用程序会需要进行该进程,但无需担忧手动创建正确光照贴图UV的耗时。Datasmith会在后台完成所有工作。

LightmapUV_MeshAndUV.jpg

左图是用Datasmith从CAD文件导入的资源;右图是展开并重新打包得到的UV。

在该范烈中,其为包含许多不同面的复杂对象,这些面已经被拆分并打包到光照贴图UV中,这样便不会有重叠面且全部包含在0,1 UV空间中。此操作可确保构建该网格体光照时,不会发生任何光照贴图错误,从而需要在虚幻编辑器外部编辑UV图表。

要检查光照贴图UV,首先在内容浏览器中选择并双击静态网格体,将其打开。

StaticMeshEditor.jpg

在工具栏中,单击 UV 按钮并选择要显示的UV通道。

StaticMeshEditor2.jpg

然后,静态网格体编辑器视口中将显示所选UV通道。

StaticMeshEditor3.jpg

若不确定哪个UV通道是光照贴图UV,可依次单击查看哪项与以上范例类似,或者使用 细节 面板查看被指定为 光照贴图坐标索引 的UV通道,以完全确认。

关于该网格体需要特别注意一点:其是包含许多面的大型网格体,而此类面在光照贴图UV中会变得非常小,因此构建关卡光照时,仍由可能遭遇质量相关的错误。可以使用以下方法解决此类问题:

  • 提高静态网格体的光照贴图分辨率。

  • 手动展开并重新导入网格体

  • 在软件应用程序中,将模型细分为更小的数据块。

光照贴图分辨率

光照贴图分辨率会提高纹理分辨率。其提高光照构建期间生成的光照贴图质量。有时光照贴图UV包含的UV图表较小但尚不足够小,因此增大纹理分辨率仍会导致质量相关的问题。而以上操作可提供有用帮助。

可在静态网格体编辑器的细节面板的 常规(General) 部分下,调整网格体的 光照贴图分辨率。找到 光照贴图分辨率 并将其设置为2的幂次方值(64、128、256、512等)。

LightmapResolution.jpg

因此,若使用该网格体,并将其所有UV图表缩放为和单个光照贴图UV匹配的大小,则光照贴图分辨率可极大影响烘焙光照和阴影信息的质量。UV图表中的某些面仍然太小,无法以可接受的分辨率存储正确光照信息,因此即使使用如2048纹理分辨率等高光照贴图分辨率仍会存在问题。

LightmapUV_UVLayout.pngLightmapUV_ArtifactsLowQuality.png

增大光照贴图分辨率可以帮助减少因光照构建导致的质量相关瑕疵。但其也会增大总体纹理内存占用量,导致生成关卡光照所需时间延长。

LightmapUV_BrokenModelBaked512.png

增加到2048光照贴图分辨率的单个网格体。

将网格体分拆为较小数据块:

切勿尝试增加光照贴图分辨率,而将模型分拆为较小数据块,这样的操作效率更高。UV图表可以高效使用更多光照贴图UV空间,因此利用此操作便能使用较低光照贴图分辨率,从内存中移除不在相机视野里的部分,最终提供更高质量的光照效果。

以单个网格体的初始UV布局为例(左)。单个光照贴图UV中的几何体过多,光照细节较易丢失,即使提高光照贴图分辨率,还是会导致光照构建不正确。将模型分拆为较小数据块(中),其现在拥有专属的光照贴图(右),但将使用更多UV空间来正确存储光照信息,在较低光照贴图分辨率下也可提供较好质量。

单击图像查看完整尺寸。

尽量在如接缝或插页边缘位置等合理位置将模型分拆解为较小部分。这样有助于隐藏各部分之间的任何烘焙问题或分辨率差异。

单个网格体,光照贴图分辨率:2048

多个网格体,光照贴图分辨率:512

在上图中,单个网格体(左)仍为暗色,即使增大光照贴图分辨率,其阴影质量却更好。UV图表未使用足够的UV空间来存储该信息,因此无法保留太多反射光。而在右侧,其质量相差无几,但由于UV图表使用的光照贴图UV空间更多,因此能够更准确地捕捉GI信息。

欲了解更多光照和构建问题的相关信息,可访问由社区维护的光照故障排除指南,其中列出诸多优秀范例示例和光照构建常见问题的解决方案。

以下是帮助用户上手UE4光照的部分链接:

材质和纹理

在UE4中,纹理将应用于可在材质编辑器中编辑的材质。如其他许多应用程序一样,材质编辑器使用基于节点的图表界面,利用其可创建应用于如静态和骨架网格体等几何体的着色器,或用于如级联等其他系统的着色器,以创建有趣材质。

image_23.jpg

虚幻引擎4使用基于物理的着色模型,类似于迪士尼“原则式”BRDF基于物理的渲染模型。这意味着将使用与现实世界关联度更高的属性而非任意属性(例如,漫射颜色和高光度)来定义材质。此类属性包括底色、金属感、高光度和粗糙度。

分配静态网格体材质的技巧

可以利用以下技巧,在内容浏览器中快速找到材质并分配给静态网格体。

  • 从内容浏览器分配材质 - 在内容浏览器中选择材质,然后在细节面板中单击材质(Material)槽旁边的 箭头 来指定所选材质。
    image_24.png

  • 在关卡的网格体中查找材质 - 单击材质(Material)槽旁边的 搜索(Search)(放大镜),可立即导航到该材质在内容浏览器中的位置。
    image_25.png

  • 重置为默认值 - 单击材质(Material)槽旁边的 重置为默认值(Reset to Default)(黄色),将材质恢复为分配至网格体的默认材质。

以下是帮助用户上手UE4材质和纹理的部分链接:

蓝图和脚本

虚幻引擎中的 蓝图可视化脚本 系统是一个完整的gameplay脚本系统,其依据的理念是在虚幻编辑器中使用基于节点的接口创建gameplay元素。和其他常见脚本语言一样,其也用于定义引擎中面向对象的类或者对象。在使用虚幻引擎4的过程中,用蓝图定义的对象通常也被称为“蓝图”。

该系统极其灵活、强大,设计者几乎可使用程序员能使用的所有概念和工具。

image_26.png

以下是帮助用户上手蓝图的部分链接:

  • 蓝图介绍 - 若刚接触蓝图,该链接将对蓝图的定义和功能进行详尽概述。

  • 蓝图快速入门 - 该指南可帮助用户通过创建首个蓝图来快速入门和运行。

  • 蓝图操作方法视频教程 - 可帮助用户进一步了解可视化脚本的精编教程专辑和视频格式资料。

Sequencer

利用 Sequencer 编辑器可通过专用多轨迹编辑器创建游戏过场动画。其是使用轨迹创作过场动画的主要方法,该轨迹则用于定义过场动画场景的构成方式。例如,利用Sequencer可使多个相机缓慢平移穿过可视化建筑场景,或使用Composure和Sequencer来进行合成。

与其他视频编辑软件类似,可创建相机轨道,然后根据需要进行拖动和重新安排来快速编辑场景。

Col05.jpg

Fabrice Bourrelly创建的“光之教堂”场景。

以下是帮助用户上手Sequencer的部分链接:

构建和发布项目

准备好开始测试,甚至是创建用户可在自身机器上打开的最终版项目时,需要使用虚幻构建系统来烘焙项目,并将其打包到standalone可执行文件中。利用该进程可轻松与他人分享文件,而他人无需预先安装虚幻引擎4即可打开项目。此外其还可通过将所有资源存储在Pak文件中来保护内容,启动可执行文件时,虚幻将使用该文件引用资源。

烘焙和打包项目的进程会执行以下操作:

  1. 文件(File)>打包项目(Package Project) 菜单中选择目标平台时,将启动烘焙和打包(Cook and Package)流程。

  2. 项目中的地图将在内容浏览器抓取引用资源,并在暂存目录中创建其副本。

  3. 烘焙完成时,虚幻编译工具会开始将此类文件和必要的引擎文件打包为无需虚幻引擎4即可运行的可执行文件。

  4. 完成后即可运行所创建的项目可执行文件以加载打包版项目。资源存储在单个Pak文件中,而任何源代码或蓝图脚本已被剔除并转换为不可访问的机器代码。

这是打包项目过程的详尽说明。欲了解更详细的过程指南和解释,参见打包项目页面。

如Android或iOS等平台的内容烘焙和打包,需要拥有特定的必备SDK或硬件,才能正确打包项目。

额外参考资料

感谢阅读本指南!本指南专为企业社区创建,由虚幻开发者提供支持,欢迎提交任何反馈或更正意见。我们将继续努力改进本文档,进一步介绍过渡到UE4时最有帮助的信息。

此外,还有部分可供学习的额外虚幻引擎4资源。请参考以下链接:

Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见