虚幻引擎4.1版本说明

Windows
MacOS
Linux

主要新功能

平台

PlayStation 4和Xbox One支持
  • 完全支持PlayStation 4和Xbox One!

    xboxone_ps4.png

  • Playstation 4和Xbox One的引擎源分别提供给微软或索尼的注册开发者。

  • 目前,将项目部署到Playstation 4或Xbox One需要使用Windows电脑从GitHub编译源码

SteamOS/Linux支持(预览)
  • 现在可以打包游戏并部署到SteamOS和Linux!

    steamos_linux.png

  • 目前,将项目部署到Linux需要使用Windows计算机从GitHub编译源码。

市场内容

元素演示
  • 还记得我们在PlayStation 4上展示的那个很酷的虚幻演示吗?这是虚幻引擎4的高端渲染能力的壮观展示,包括动态照明和阴影实时反射、次表面散射和GPU支持的粒子效果。

    Elemental.png

数学大厅,新内容示例关卡
  • 数学大厅示例介绍了基本矢量数学和各种数学函数背后的概念。

    math_hall.png

新项目模板

飞行模板和滚动模板
  • 我们创建了两个新的项目模板,演示了简单的飞行和滚动角色移动。

  • 飞行模板(C++和蓝图)使用简单的飞行移动:

    flying_template.png

  • 滚动模板(C++和蓝图)以基于物理的滚球作为玩家角色:

    rolling_template.png

编辑器和工具

新内置编辑器教程
  • 我们添加了新的内置编辑器教程。当您第一次遇到这些功能时,这些教程将自动出现。

    editor_tutorials.png

  • 级联粒子编辑器教程 介绍创建粒子系统和效果时使用的基本用户界面和概念。

  • 材质编辑器教程 介绍有关创建材质的基础知识。

  • 静态网格体编辑器教程 介绍用于设置静态网格体的界面和工具。

  • Persona动画编辑器 教程介绍不同资源类型和模式的各种用户界面元素和概念。

场景大纲视图文件夹系统
  • 现在,您可以在场景大纲视图中将Actor组织到文件夹中。

    scene_outliner_folders.png

  • 创建按钮将为您创建一个包含当前选定Actor的新文件夹。

  • 文件夹上的可见性切换会影响其包含的所有Actor。

编辑器动态消息
  • 编辑器现在有内置动态消息。您可以使用编辑器右上角的新按钮访问它。

  • 动态消息将告诉您新的市场内容、视频教程和博客文章。

    news_feed.png

资源删除助手
  • 该功能通过帮助您交互式地检查和修复引用,使删除资源变得很容易。

    DeleteAssetTool001.png

  • 允许对仍然在磁盘或内存中引用的资源进行优雅的清理

  • 您可以单击任何引用的资源来导航到它并手动修复它。

  • 您可以替换引用,正式的说法是“合并”。

  • 您可以执行强制删除,也可以取消并自己处理引用。

  • 允许多个同时删除。

  • 即使一个资源被其他资源引用,只要它们也被删除,它也不会将其标记为一个问题。

  • 引用导航

  • 双击引用资源将打开其编辑器

  • 如果一个资源在开放地图中被引用,双击地图资源将会将您带到该开放地图中。

拖放目录导入
  • 您现在可以选择多个具有纹理、网格体和动画的文件夹,并将它们直接拖放到内容浏览器中,以导入这些文件夹中的所有内容。

    DragAndDrop.png

取消操作历史记录窗口
  • 编辑器现在有了访问取消操作历史记录的方法。

    UndoHistory02.png

  • 您可以从Windows菜单(Windows > 取消操作历史记录(Undo History))中访问取消操作历史记录(Undo History)窗口。

新内容:重新映射视口功能按钮
  • 现在我们允许用户重新映射视口的WASD功能按钮。

  • 您可以在 编辑器首选项(Editor Preferences)>键盘设置(Keyboards Settings)>视口导航(Viewport Navigation) 下找到这些设置。

    ViewportControls.png

新内容:调试直方图可视化
  • 您现在可以绘制世界场景中浮点值的直方图(图表)。

    debug_histogram.png

  • 您可以随着时间的流逝记录属性或游戏的其他方面的值,并将其可视化为世界场景中特定位置的直方图。

  • 值可以被记录,直方图可以从C++代码和蓝图中绘制。

    debug_histogram_nodes.png

  • 注意:该功能是为调试目的而设计的。正常游戏过程中不推荐使用调试绘制。

翻译编辑器(预览)
  • 翻译编辑器使您更容易编辑游戏代码和资源中字符串的翻译。

    TranslationEditor03.png

  • 注意:该工具仍处于早期开发阶段。可以在实验性部分的编辑器首选项中启用此工具。

蓝图

跳转到图表中的连接
  • 您现在可以右键单击引脚并跳转到连接。

    JumpToConnections.png

类动态投射
  • 现在,您可以安全地在蓝图中兼容的对象类型之间进行转换。

    DynamicCasting.png

改进的蓝图组件编辑
  • 现在可以在蓝图编辑器窗口之间拖放组件节点。

  • 这将在新蓝图中创建一个新的组件变量,该变量将从原始蓝图继承其属性(变量名除外,以避免冲突)。

  • 现在可以撤消/重做组件附件和分离操作。

  • 这也适用于“指定新的场景根组件(Make New Scene Root)”操作。

重要升级说明

升级项目

在4.1中运行4.0项目可能需要一些步骤。

  • 升级纯蓝图项目

    • 您可以在新编辑器中正常加载现有项目。

    • 注意:一些蓝图API可能在不同版本之间发生了更改,这可能会在内容中引起警告。阅读 API更改 部分了解更多信息。

  • 升级C++代码项目

    • 您将需要为新版本的虚幻引擎重新编译C++项目。

    • 在游戏文件夹中找到.uproject文件,并右键单击它。(在Mac上,您还可以使用命令+单击)

    • 选择 切换虚幻引擎版本(Switch Unreal Engine Version)-> 4.1(Mac上是在服务(Services)菜单中)

    • 右击可生成新的C++项目文件,然后正常重新编译游戏。

    • 注意:一些C++ API可能在不同版本之间发生了更改,这可能导致编译错误。阅读 API更改 部分了解更多信息。

  • 抱歉给您带来不便!我们正在努力简化未来版本的升级过程。

已知问题

  • 如果安装了Xbox One SDK,对于名称中有下划线的项目,生成Visual Studio项目将会失败。

  • Xbox One和Playstation 4还没有完全支持在任何父目录中包含空格的项目。

  • Steamworks目前还不支持Mac,我们正在开发它!

  • 射击游戏需要使用来自GitHub的源码作为专用服务器来编译。

  • 用第一人称模板创建的项目可能会在Playstation 4上崩溃。

  • 使用编辑器中的“启动(Launch On)”按钮部署到Mac,元素演示崩溃。

  • 如果登录了游戏中心,iOS上的Tappy Chicken在启动时就会崩溃。

特别鸣谢

我们要感谢所有在这个版本中贡献代码的优秀开发人员。我们对你们所做的工作深表敬意和赞叹!

Release Notes

Marketplace Content

  • ShooterGame: Now supports Xbox One and PlayStation 4 deployment.

    shooter_game.png

  • Memory Game: A card-matching memory game created entirely in Blueprints.Optimized for mobile devices!

    memory_game.png

  • Effects Cave: Spelunking has never been this fun! See the pretty things you can make to add richness to your world by exploring the Effects Cave.Using the Cascade visual effects editor you can layer on countless details including GPU-powered particles, dynamically lit sparks, wispy puffs of smoke and more.

    effects_showcase.png

  • Realistic Rendering: Easily build true-to-life environments or emulate architectural visualizations using UE4's physically-based material system, the improved Lightmass global illumination system and photometric lighting.Supports Oculus Rift!

    realistic_rendering.png

  • Blueprint Office: Shows a wide variety of use cases for Blueprints ranging from level design tools to intelligent security systems to sophisticated AI behavior.Each example includes a brief in-game explanation.

    blueprints_demo.png

Learning Resources

End User License Agreement (EULA)

  • Licensees are now permitted to publicly distribute Example Code (code residing in the Samples and Templates folders).This is an exception to the rule prohibiting distribution of Source Code publicly.

  • Added the following exceptions to licensees' royalty obligation:

  • Licensees are not required to pay royalties on the first $3,000 in gross revenue per Product per quarter.

  • If Product revenue is less than $3,000 in a quarter, licensee is not required to report revenue for that Product.

  • Financial winnings from awards are exempt from royalties.

  • Licensees are now permitted to post Source Code snippets up to 30 lines in length on public forums for discussion purposes.

Unreal Engine Launcher

  • New: Install multiple versions of Unreal Engine side-by-side.

  • Use the Launcher's new Version Selector drop-down to choose which version you want to install and run!

  • New: You can now uninstall the engine versions right through the launcher using a new 'Uninstall' button on the main UI.

  • New: Launcher Marketplace pages now show download size.

  • New: The Marketplace now supports different versions of items.

  • New: The EULA is now shown and accepted through the launcher.

  • New: Project files can be associated with engine versions installed through the launcher.

  • New: The Unreal Installer and Launcher are now localized for Korean and Japanese.

  • For the launcher you can select a language in on the login screen.

  • Fixed not being able to queue Marketplace items while the Engine is downloading.

  • Fixed installer not warning users if they did not have Windows 7 SP1 installed.

  • Fixed an issue preventing Unreal Engine shortcuts from being removed from the desktop on uninstall in some cases.

  • Fixed rare issue with being stuck on "Syncing your account".

  • Fixed cancelled automatic downloads so they will not resume.

  • Fixed self-update ignoring empty files.

  • Fixed UI size information not displaying with decimal places.

  • Fixed an issue causing a failed installation to start all over again rather than resuming from previously successful files.

  • Fixed a rare issue where a failed data file download could cause the install to never finish.

  • Fixed Mac Launcher crash on close.

  • Fixed download size indicator to support showing the compressed download size rather than uncompressed size.

  • Fixed some UI issues with progress percentage information.

Editor and Tools

  • General Editor

    • New: Improved the 3D viewport grid!

      • Removed the grid dots for a cleaner view.The grid is now also scaled according to the grid snap settings.

      • Perspective grid precision improved with thinner lines.

      • Orthographic grid now has power of 10 major gridlines, soft fading transitions between levels, and colored axis lines.

    • New: Added a Preview Meshes preference that allows customization of meshes displayed in viewports when holding the Backslash key.

    • New: Icons for your project can now be assigned via Window/Project Settings.

    • New: Startup Movies for your project can now be assigned via Window/Project Settings.

    • New: Pressing the C key now creates comments in the Material and SoundCue editors.

    • New: Added an option to invert middle mouse pan movement.Invert Middle Mouse Pan option in the Editor Preferences -> Viewports.

    • New: Added search support in the Placement Browser.

    • New: Holding Ctrl now prevents Vertex Painting from de/re-selecting Actors.

    • New: Added support for Ctrl + Backspace and Ctrl + Delete to editable text boxes.

    • New: Added Enable Sound option to Play-In-Editor settings.

    • New: Save window now displays "Save Map" or "Save Asset" depending on what's being saved.

    • New: Added ability to scale individual sub-curves to the curve editor.

    • New: Content is now autosaved by default, and the notification shows you the number of packages that will be saved.

    • New: Pressing F4 to view details will now potentially spawn a new Details panel if all the currently open ones are locked.

    • New: Browse button in the Content Browser context menu now works on unloaded objects.

    • New: The Reset Layout feature has been moved to the Window menu from Editor Preferences.

    • New: Property names can be set to display as they are in code (English) on the Region & Language editor preferences.

    • New: You can now customize the selection colors in the Editor Preferences.

    • New: You can now override the far view plane on a level editor viewport.

    • New: Columns are now sortable in Save Content dialog.

    • New: 3D marquee select has been re-added with the same original keybinding (Ctrl + Alt + Left Click Drag).

    • New: Added a message log link to diagnose load errors in-editor.

    • New: If there is an active camera safe frame, the High Resolution Screenshot UI allows you to set the capture region to that safe region.

    • New: Added prompt to restart the editor after you've enabled or disabled a plugin in the Plugins Editor.

    • New: Improved how the zoom slider in the Texture Editor interacts with the Fit to Viewport setting.

    • Improved decal scaling performance in the editor.

    • Improved Asset Discovery time in the editor.

    • Improved Arrow Component readability at a distance.

    • Updated Code View functionality to now exist in a plugin.

      • Please enable the Code View plugin to reactivate this functionality (Window Menu -> Plugins -> Editor -> Code View).

    • Fixed Region & Language editor preferences to be more user friendly.Changing them should be less confusing or awkward.

    • Fixed High Resolution Screenshot facility.

      • Screenshot capture is now limited to the viewport from which the High Res Screenshot action was selected.

    • Fixed Editor Preferences not listing all available languages and regions.

    • Fixed Select Actors using this Asset not selecting Actors in other streaming sub-levels.

    • Fixed selection problems in orthographic viewports due to mouse tests not extending from beyond the origin plane.

    • Fixed Actors not remaining selected after copying Actors from multiple levels into the clipboard.

    • Fixed global shortcut keys not functioning in floating windows in some cases

    • Fixed safe frames and aspect ratio bars not displaying when locking a camera in Matinee when no camera is selected.

    • Fixed viewport settings not being saved into the layout preferences file instead of the editor preferences files.

    • Fixed notifications not being anchored to their appropriate monitor work area.

    • Fixed copying text from the Output Log not copying lines in the correct order.

    • Fixed Output Log auto scrolling.

    • Fixed level locking changes in the level browser not being able to be undone or redone.

    • Fixed unintuitive project switching by displaying the name of the project in the splash screen.

    • Fixed survey notification not fading away instantly after clicking Cancel to close it.

    • Fixed Actors being selected when the viewport is hiding the layer they are in.

    • Fixed Tutorial window to no longer play sounds.

    • Fixed the white square artifact with the Virtual Joystick by adding a StartupDelay function.

    • Fixed crash on save when FindObject is called.

    • Fixed curve handle movement in Viewports to no longer be inverted.

    • Fixed dropping assets onto Brush edges/verts, it now leaves them at the correct location.

    • Fixed SVN binaries not being included with the editor when installed from the launcher.

    • Fixed tooltips not appearing in the Window options on the main menu.

    • Fixed Frame rate settings being allowed to go below zero.

    • Fixed StaticMesh scaling via "ScaleMeshes" console command not taking into account the existing BuildScale into consideration before making any changes.

    • Fixed home button not appearing in the tutorial window appears after viewing Blueprint tutorials.

    • Removed unused splash screens.

  • FBX

    • New: Added an Import All button to the FBX import dialog.This will import all selected files with the same FBX settings without being asked more than once

    • Changed FBX Import Options Window for clarity:

      fbx.png

    • Changed the default setting of Import Meshes in Bone Hierarchy, under the Skeletal Mesh import settings, to be enabled by default.This will result in any non-skinned meshes in the bone hierarchy being imported as actual meshes and not as bones.

    • Fixed importing with Materials and Textures that are the same name as each other or a mesh.This will no longer cause a crash, instead unique names will be generated for each conflict.

    • Fixed overlapping nodes on Materials imported from FBX.

  • Content Browser

    • New: You can now rename folders by right clicking on them and selecting Rename.

    • New: Added new Content Browser view options:

      • Show Only Assets in Selected Folders will only show assets in the currently selected folder when searching or filtering.

      • With Real-Time Thumbnails enabled, any loaded asset will show material animation.

    • New: Changes to Behavior Tree assets can now be displayed interactively while using the Diff Tool.

    • Fixed the Developer Folder appearing in the Content Browsers breadcrumb trail if the Developer Folder option is disabled.

    • Fixed Textures in thumbnails often drawing with blurry graphics by improving streaming for thumbnail Textures.

    • Fixed not being able to type immediately into Content Browser search when window is summoned.

    • Fixed move/copy to only prompt for asset load once per folder group move/copy.

  • Matinee

    • New: Matinee now supports rendering to PNG and JPEG formats (along with BMP and AVI).

    • New: Safe frames and aspect ratio bars can now be displayed when locking a camera and in Matinee when a non-camera is selected.

    • New: Notification now occurs when attempting to delete an Actor from the Viewport while Matinee is open.

    • Optimized invalidation of curve editor viewport, which improves Matinee's performance.

    • Fixed inconsistencies with how Undo/Redo works in Matinee compared to other editors such as Cascade.

    • Fixed not being able to interact with graph labels and buttons while in Zoom Mode.

    • Fixed Slomo tracks not being able to slow the play rate down below 10%.

  • Persona: Animation Editor

    • New: You can now select and edit multiple bones at the same time in Persona.

    • New: You can now save assets straight from Persona's built-in Asset Browser.

    • New: Animation Notifies can now be deleted by selecting them and pressing the Delete key.

    • New: You can now open assets directly from Blueprint nodes that reference them.

    • New: Added function to Persona to allow the user to remove unused bones from a skeleton.

    • New: Added recently opened file history in the form of Forward and Back browser buttons in the Asset Browser in Persona.

    • New: Added filters to Asset Browser in Persona.

    • Changed the setting of the default preview mesh on skeletons to make sure they never start will a NULL mesh.

    • Fixed not being able to undo and redo changes to bones.

    • Fixed some Persona settings not being remembered between sessions.

    • Fixed Persona mode widgets not indicating dirty state.

    • Fixed a crash in Persona's skeleton tree context menu.

    • Fixed the preview viewports not drawing when dragging a slider in Persona.

  • Source Control

    • New: P4 plugin now supports P4HOST masquerading, password login and connection to stream depots.

    • New: P4 can no longer connect to workspaces that do not map to your project (and similarly for SVN working copies)

    • New: Added toast popup when successfully checking in.

    • Fixed Perforce source control plugin not supporting Unicode workspace names and user names.

  • Material Editor

    • New: You can now zoom in and out by holding Left + Right Mouse Buttons and dragging.

    • New: Material Attributes can now be connected to Feature Level and Quality switches.

    • New: Added context sensitivity when dragging off pins in the Material Editor.

    • New: Lighting-specific options in the Material Details are now grayed out when Unlit mode is active.

    • New: Changed Material statistics to be displayed in their own tab.

    • New: Added New Mobile Stats Icon for Material Editor.

    • New: Added title coloring for Material Expression nodes.

    • New: Added option to Panner Material Expression to use fractional component of the time calculation to improve accuracy.

    • Exposed default material values that were missing and added tooltips to non-required inputs.

    • Fixed Material asset name not being displayed in the Material Editor Title tab.

    • Fixed propagating changes from material functions to any materials or functions using them.

  • Geometry Editing

    • New: Geometry brushes will now attempt to keep the material information even when their core parameters are altered.

      • Changes where the number of polygons remain the same are completely supported.

      • Changes where the number of polygons differ only support a single material across the whole mesh.

    • Fixed dragging and dropping Geometry Brushes into the Scene Outliner not working correctly.

    • Fixed not being able to scroll through the various Geometry Editing mode controls.

    • Fixed legacy builder brush visible in the 3D scene while Geometry Editing mode is active.

    • Fixed the Lathe tool to create a brush.

    • Removed Volumetric and Sheet brush shapes as they were non-functional.

  • Landscape and Foliage

    • New: Landscape splines now have a Max Draw Distance setting for meshes on the spline.

    • New: Added new Landscape LOD preview settings to viewports.

    • New: New controls for collision settings were added to Foliage tool.

    • New: Added Resample option for Change Component Size tool.

    • New: The Landscape Spline sprite automatically scales with the width of the spline to prevent them from getting too big.

    • New: The Landscape move-to-level tool will now operate on the component under the cursor when there is no component selection active.

    • Updated the order of the Landscape Visualizers menu.

  • Mesh Paint Tool

    • New: Paint brush radius is now saved with your editor preferences.

    • Updated the default paint brush radius to 128.

  • Data Table Editor

    • New: To aid in readability, even and odd rows now have different background colors.

    • New: Search has been implemented in the Data Table Editor.

  • Scene Outliner

    • New: More options for managing Actors and folders in the Scene Outliner right click context menu.

    • Fixed Undo/redo with folders in the Scene Outliner.

  • World Browser

    • New: Added option to handle cooking for worlds created by World Browser -map=PersistentMapName?worldcomposition.

    • New: Added time threshold between tile distance streaming load/unload requests.Can be changed in configuration files: TilesStreamingTimeThreshold.

    • New: Added position snapping for level tiles, use Ctrl+Left Click Drag.

    • Replaced World Browser async loading of level tiles with a blocking load and added "long operation" message.

    • Removed the Always Loaded level type.

  • Device Profile Editor

    • New: Device Profile Editor is now always available through the Window Menu -> Device Profile Editor

    • Updated the device profile editor UI with a layout which reflects its primary usage.

    • Updated CVar addtion, removal, and parenting to be a lot more evident for a profile.

  • Translation Editor

    • New: Translation Editor now searches the Engine, Editor, and the currently loaded project's directories for localization files to determine which projects/languages can be translated.

    • New: Added event triggered by a property change to the translation data object to write the data to file, to prevent data loss due to user forgetting to save, or the editor crashing.

    • Fixed Translation Editor to read local cached versions of old manifests when possible instead of syncing them from Source Control again.

Blueprints

  • New: Added undo/redo support for component attach/detach operations in Components mode within the Blueprint editor.

  • New: Added undo/redo support for repositioning graph nodes in a Blueprint graph.

  • New: Added proper undo/redo support for duplicating components in Components mode within the Blueprint editor.

  • New: Added support for dragging components between 2 different Blueprint editor windows in Components mode.

  • New: Added support for drag-and-drop with multiple components selected in Components mode within the Blueprint editor.

  • New: Added a graph node section in the details view of the Blueprint editor that provides the ability to rename nodes that the user can rename.

  • New: Added ability for Blueprint cast nodes to cast from one interface to another.

  • New: You can now multiply LinearColors by floats using a Float * (LinearColor) Blueprint node.

  • New: Added a new ParseIntoArray function for easily splitting up strings.

  • New: Variable Get/Set nodes can now display Rich Tooltips.To view them, mouse over a node and hold Ctrl+Alt.

  • New: Alt + Right Click can now be used as an alternative to zoom Blueprint graphs.

  • New: Added menu extensibility hooks for additional items in the Debug Object drop down.

  • New: Graph nodes can now be renamed via the details panel when a node is selected

  • New: Added support for searching Blueprint Interfaces.

  • New: Renaming Blueprint Interface's functions now properly renames the functions in implementing Blueprints.

  • New: Added the Ability to set the PlayRate of a Montage from within Blueprint.

  • New: Added Impact Velocity parameter to OnProjectileBounce, to allow blueprints to override bounce velocity vector.

  • New: Added "value (clamp) range" exposure to numeric variables in Blueprints to go along with "slider UI range."

  • Updates allowing multiple pending latent actions at a particular call site from a Blueprint.

  • Fixed Combo button menu scaling in the Blueprint Editor.

  • Fixed Realtime rendering in the Blueprint Components mode Viewport.It is now disabled when Components mode is deactivated within the Blueprint editor.

  • Fixed the Toggle Particle System Helpers option to work on Blueprint Actors that contain Particle System Helpers.

  • Fixed Blueprints to be properly flagged as being modified when toggling between absolute and relative transform settings.

  • Fixed not being able to undo/redo after moving nodes around on the graph.

  • Fixed Grid Snap while translating components in Components Mode.

  • Fixed Sprite Component visualizers switching to the default "Actor" icon in the Blueprint editor preview during Play in Editor or Simulate in Editor.

  • Fixed renaming Blueprint Interface functions, they will now properly rename in implementing Blueprints.

Rendering

  • General

    • New: Added ability to disable parts of the DBuffer decals effect (Material Decal Response).

      • You can mask color, normal, roughness.

      • This can free up texture sampler units, improve performance, and gives more control.

    • New: Added feature to choose graphics adapter (r.GraphicsAdapter) or let the system do this automatically

      • By default, this favors non-integrated graphics card (at the moment we check for "Intel" in the adapter name).

    • Improvements to Sky Lights:

      • New: Movable objects receive sky shadowing from static shadow casters.

      • Fixed TLM_Surface materials to render sky reflections properly.

    • Improved glossy screen space reflections to reduce noise.

    • Fixed situation that could cause incorrect viewport dimensions to be calculated when setting render target to lower mip levels with the D3D11 RHI.

      • Fixed some possible incorrect casting of D3D texture objects.

  • Android

    • New: Reflection capture data is now stored in the map package.

      • This allows cooking for ES2 to always have valid reflections for maps that have been resaved.

    • Optimized motion blur, UIBlur, and screenspace ambient occlusion.

    • Improved CPU performance by setting affinity mask for the gamethread, renderthread and eventthread.

    • Improved GPU performance by turning on DisjointTimerQueries on Adreno 330-based devices with a driver later than version 53.0.

    • Updated the CVar r.DisjointTimerQueries to enable GPU frametime measurement in STAT UNIT on device.

Gameplay and Framework

  • New: In the Input section of the Project Settings you can now indicate that the mouse should simulate touch behavior.

  • This means only one set of events needs to be mapped for simple touch games being played on PC.

  • New: Added Audio Settings section of Project Settings in which the Default Sound Class and Default Base Sound Mix can be specified.

  • New: Splitscreen options added to Maps & Modes section of Project Settings.

  • New: Added path simplification to path following component using visibility tests, to skip some irrelevant path points.It is disabled by default.

  • New: Added landscape collision data cooking.Cooked landscapes will now create collision objects from a binary stream of cooked data, which improves level streaming performance.

  • New: Text Render Actors now generate and cache static vertex and index buffers.

  • Improved the way Morph Targets calculated their morphed normal.

  • Fixed the lack of feedback if a module fails to load due to a lack of compatibility.An error message will now be displayed.

  • Fixed editor-only sprites being loaded while cooking.

  • Fixed movement components to correctly handle analog input.

  • Fixed a crash in material indices and LOD mapping indices.

  • Fixed Async package loading no longer allows objects to be post-loaded before they are pre-loaded.

  • Fixed the example device profile selection plugin requirement to launch UE4.

  • Fixed Always Loaded levels to be flagged as Should be Visible by default.

Networking

  • General

    • New: Character Movement Component movement mode is now replicated.

    • New: Launch Character can now be simulated client side for non-locally controlled characters.

    • New: The setting Only Relevant to Owner is now available to Blueprints.

    • Improved character movement on moving platforms for remote network clients and for simulated proxies.

  • PlayStation 4

    • Socket subsystem support for UDPP2P sockets.

Animation

  • New: Added support for reference pose scale.

  • Fixed AnimMontages to no longer allow branch points to overlap.

Physics

  • New: PhysX and APEX have been upgraded to 3.3.1 and 1.3.1.

  • In some cases it may be necessary to recook physics data.

  • This upgrade fixes some physics related bugs.See NVIDIA release notes for more info.

  • New: Maximum angular velocity of a BodyInstance has been exposed in code and blueprints.

  • New: Pawns will now collide with destructible mesh.Large and small chunks can be set to get different interaction with pawn.

  • New: Breakable joints are now available for ragdolls and physics assets.

  • New: Support for cloth on ragdolls and physics assets.

  • Updated soft physics constraints to use body mass implicitly.

  • Updated the Async physics scene to be disabled by default.

  • This feature is somewhat advanced and uses more memory.As such, it has been turned off by default and can be changed in the Edit Menu -> Project Settings -> Physics -> Simulation category.

  • If Async scene is disabled, all Actors are placed in the regular scene regardless of the Enable Async flag on the Actor.

  • Updated the player Pawn to no longer interact with the Async scene by default.

  • Fixed overlap event related bugs.Correct behavior related to overlap flags may break old content relying on bad behavior.

  • A collision between two objects can be set to Ignore, Overlap, or Blocking.

  • An overlap event will occur if two objects Overlap and both have the Generate Overlap Events flag set to true.

  • A bug in the code made it so that in certain situations an overlap would trigger even if one of the overlapping objects had the flag set to false.

  • This means overlap events that were previously firing could now stop due to improper flagging.

  • Fixed Overlap events to only fire when collision is marked as overlap.

  • There was a bug where in some cases an overlap event would fire even if a collision was marked as Blocking.

  • Fixed Hit Events now require both objects to opt in by enabling Simulation Generates Hit Events.

Audio

  • New: Added Enable Sound option to PIE settings.

  • New: Added Add Input button to appropriate Sound Nodes.

  • Improved DialogueWaves so they can be played immediately after creation/modification.

  • Limited the Random Sound node choices in Play in Editor if Preselect at Level Load setting is used.

Core

  • New: UnrealBuildTool can now be configured using an XML configuration file!

  • It looks for the BuildConfiguration.xml file in two possible locations (Engine/Saved/UnrealBuildTool and My Documnets/Unreal Engine/UnrealBuildTool).The first one should be used for branch/engine configurations, while the second one is for personal settings.Notice that environmental variables settings will be overridden by those values if set.

  • The syntax is described in \Engine\Programs\UnrealBuildTool\BuildConfiguration.xml.

  • New: Added support for cross-compiling Linux client.

  • New: All platform memory and allocator memory statistics are now available through the stats system.

  • New: Added metadata for threads and thread group for the stats system.

  • New: Improved save format of the stats files (not fully utilized yet).

  • New: [Windows] Shell integration now supports multiple engine versions side by side.

  • To add an engine installation, or to set up shell extensions and file associations for the first time, run UnrealVersionSelector from each Engine\Binaries\Win64 directory.

  • Each .uproject file can be configured to open with a different engine installation.

  • New: The -UTF8Output command line argument can be passed to any program using the engine to force stdout into UTF-8 mode.

  • Use this if you are getting question marks in your Unicode strings being logged.

  • Improvements to the Visual Studio accessor (particularly for Express).

  • Fixed InstallVisualizers.bat complaining about no version of Visual Studio installed, when only Visual studio 2010 is missing.

  • Fixed UnrealBuildTool to raise an error early about attempting to build the Editor in a Win32 configuration.

  • Fixed the size of the internationalization libraries.

  • Internationalization now loads its data from a binary file rather than from a static library.

Platforms

  • Android

  • Improved Android device detection.It is now threaded and more efficient in general.

  • Fixed Launch showing texture formats not supported by the connected Android devices.It will now only display texture formats that are supported by the connected Android devices.

  • Mac

  • New: Packaging on Mac now creates a self-contained app bundle.

  • New: Mac UE4 now uses our crash reporter.

  • New: Added ability to use Mono installed on Mac instead of the one bundled with the engine.

  • New: Added support to UBT for generating dSYM debugging symbol bundles on Mac OS X.

  • New: Implemented text input method system for Mac platform.

    • This uses the native Cocoa InputMethod services on Mac OS X to support the different input methods.

  • Simplified Xcode project and improved code indexing in Xcode.

  • iOS

  • New: Added a device enumeration for iPad mini with retina display.

  • New: Added experimental support for showing the Game Center leaderboard in-app (EXPERIMENTAL_ShowGameCenterLeaderboard)

  • New: Added -compress=best command line for Shipping iOS via Windows workflow builds

  • Various improvements and bug fixes to iAd support.

  • Fixed some threading issues with IOS gamecenter.

  • PlayStation 4

  • New: Added PlayGo Support.

  • New: Implemented Achievements.

  • New: Added support for shader scratch memory.

    • Enable with r.ShaderScratchBuffers=1 in the ConsoleVariables.ini file.

  • New: HZB occlusion culling now supported on PS4.

  • Added detection of render target/shader mismatches at runtime.

  • Updated render target output formats to be set through ModifyCompilationEnvironment rather than using the SLOT defines in the shader files.

  • Xbox One

  • New: Added 10:10:10 final color output on Xbox One.This allows us to remove quantization noise in tonemapper, which is faster.

  • New: Screen safe area is now implemented.

  • New: Implemented Achievements.

  • Enabled optimizations for all pixel shaders.

  • Improved XAudio2 implementation to be more feature complete.

  • Fixed various GPU hangs.

UnrealVS (Visual Studio Extension)

  • New: Command Line box now automatically adds the game project file for 'Game' projects in UE4.sln.

  • New: Visual Studio's Customize feature now supports UnrealVS' tool bar commands.

  • New: UnrealVS Quick Build menu now allows easy access to building in any configuration without changing the config in the IDE.

  • New: Added logging to help debugging.

  • Changed code projects for game-specific editor builds (e.g. MyGame "Debug Editor|Win64") no longer need the project added to the command line in UnrealVS.

  • Previously the UnrealVS command line args to debug the editor for the example above would have been "MyGame.uproject "

  • The command line in UnrealVS for the example above is now just "", UnrealVS adds the project name automatically when the project is run.

  • The project name is still passed to the editor executable but UnrealVS now adds it automatically and does not display it.

  • Existing command lines will work as before but will display differently.

  • If no project name is supplied, UnrealVS should strip it from the displayed command line and popup a warning dialog.

  • Fixed Startup Project selector and Batch Build to correctly recognize executable projects on non-Windows platforms.

API Changes

Gameplay and Framework

  • Added bForceRescan parameter to IAssetRegistry::ScanPathsSynchronous.If true, path scanning not ignore paths that have already been scanned.

  • Added GetDerivedClasses to IAssetRegistry.This is just a wrapper function for the pre-existing GetSubClasses.

  • Added a flag to disable blue onscreen messages in DrawTransition in GameViewportClient.

  • Added ability for Blueprints to use GetOverlapInfos.

  • Added OnClosed delegate as a parameter to IOnlineExternalUI::ShowLoginUI.

  • Added a flag to disable blue onscreen messages in DrawTransition in GameViewportClient.

  • Added support for loading an ObjectLibrary from multiple paths, and a constructor for easily creating an ObjectLibrary in memory.

  • Improved the support for Blueprints in an ObjectLibrary when calling UObject::CreateLibrary.If the bHasBlueprintClasses is true, it will check the type for you.

  • Renamed FGameWorldContext to FLocalPlayerContext, as it binds to a player and not a world.

  • Renamed GetWorldContextFrom functions returning a World Context reference to GetWorldContextFrom*Checked.

  • GetWorldContextFrom now returns a pointer and returns NULL if no WorldContext exists for the supplied input. Removed FSimpleReticle from AHUD.You can add this to your subclass if desired.

  • Removed unused lifecycle event OnEngineHasLoaded from AGameMode.

  • Removed SGameWidget class as it is no longer necessary

  • Removed PendingLevelPlayerControllerClassName from GameEngine and replaced it with PendingLevelPlayerControllerClass in LocalPlayer.

  • This makes it work like the other PlayerController references, and avoids a confusing warning on every map join

  • Changed AActor::CalcCamera to consider whether a component is activated when trying to find the camera component to use (allowing selection between multiple camera components by managing activation).

  • Made SKismetLinearExpression more permissive in what it will show as a function (now tries to do something with any pure K2Node with one output).

  • ADebugCameraController and ADebugCameraHUD can now be extended and accessed outside of the Engine module.

Editor and Tools

  • Slate drag drop operations now use RTTI that is compatible with inheritance.This allows DragDrop::IsTypeMatch to work properly allowing for static casting to any level of the inheritance hierarchy.

  • Please replace previous instances of GetTypeId in FDragDropOperation derivatives with DRAG_DROP_OPERATOR_TYPE.

  • FSlateApplication::GetDragDropReflector() is now obsolete and has been removed.

  • Removed unused Linked Obj Editor framework

Platforms

  • Mac

  • The minimum supported Mac OS X version is now 10.9.2.

    • We no longer support OS X versions prior to 10.9.2 due to OpenGL driver bugs & feature deficiencies that won't be fixed in earlier versions.

  • Mac build is now using OS X 10.9 SDK, code and compile settings were updated to be compatible with Xcode 5.1.

  • Config files on were moved to ~/Library/Preferences, logs to ~/Library/Logs, all other files from Saved folders are now in ~/Library/Application Support/Epic.

  • PlayStation 4

  • Specification of TitleID, package PassCode, and other data should now be in a text file in your project directory under Build/PS4/PackagingDataPS4.txt.This replaces the old metadata system in UBT.Examples can be found in ShooterGame, and the base Engine/BuildPS4 directories.

  • Xbox One

  • Code updated to build against March 2014 XDK.

  • Deprecated functions (D3DAllocateGraphicsMemory, etc) have been removed/replaced.

Core

  • FPlatformString::Stricmp now converts to lower case to match std::stricmp.

  • This may result in slightly different sorting orders if your strings only differ by underscores or any other character between the ASCII lower and upper case ranges.

  • Warnings are now issued during bad string conversions (e.g. Unicode characters which can't be represented as ASCII).

  • You may notice extra debug text in the output log if this happens often in your code

  • TArray::Append and TArray::Insert are now overloaded to allow the insertion of multiple elements at once.

  • TSet is now accessed through operator [] instead of operator ().

  • You can use now TObjectRange in the same way you use TobjectIterator for when you want to use C++11's ranged-for syntax.

  • Example: for (UClass* Cls : TObjectRange())

  • Removed unused property flag CPF_AlwaysInit.

  • Removed unused struct flag STRUCT_Transient.

  • Added support for saving and loading FVector4 to config files using GConfig->SetVector4 and GConfig->GetVector4.

  • Licensees using cultures (locales) other than the following languages will need to rebuild ICU's data to include that locale data:

  • German - de, English - en, Spanish - es, French - fr, Hindi - hi, Italian - it, Japanese - ja, Korean - ko, Polish - pl, Portuguese - pt, Russian - ru, Swedish - sv, Chinese - zh

  • DrawDebugHelpers: added support for displaying a Histogram of float values.Use FDebugFloatHistory to record samples, and DrawDebugFloatHistory to draw in game.Also available in blueprints.

Networking

  • Modified PreReplicatedRemove, PostReplicatedAdd, and PostReplicatedChange functions on FFastArraySerializerItem to also have a parameter representing the owning array serializer.

  • Exposed bOnlyRelevantToOwner setting to blueprints.

Animation

  • New: AnimInstance now has a CalculateDirection function for BlendSpaces.

Select Skin
Light
Dark

欢迎来到全新虚幻引擎4文档站!

我们正在努力开发新功能,包括反馈系统,以便您能对我们的工作作出评价。但它目前还未正式上线。如果您对此页面有任何意见与在使用中遭遇任何问题,请前往文档反馈论坛告知我们。

新系统上线运行后,我们会及时通知您的。

发表反馈意见