プロダクション向けのカメラ レンズのキャリブレーション

バーチャル プロダクション用のカメラをキャリブレーションする。

Windows
MacOS
Linux

目標

このクイック スタート ガイドでは、プロダクション環境で Camera Calibration プラグインを使用して、レンズの歪み および 節点オフセット をキャリブレーションする手順について説明します。

目的

  • ライブ ビデオ フィードが提供されるようにカメラを Unreal Engine (UE) に接続する。

  • Camera Calibration プラグインを使用してレンズの歪みをキャリブレーションする。

  • Camera Calibration プラグインを使用して、トラッキング システムの節点オフセットをレンズに合わせてキャリブレーションする。

1 - 必要な設定

このガイドでは、ソース ビデオ入力にプロダクション カメラ、オプティカル カメラのトラッキング システム、AJA Kona 5 を使用します。

マスター クロックはオプションで、AJA Kona 5 にタイムコードと同期を提供します。プロダクション環境では、プロダクション カメラとカメラ トラッキング システムにも同期とタイムコードを供給することをお勧めします。同期とタイムコードは、ライブ ビデオでの CG コンポジットを進る場合に、レイヤー同士が同期していることを確認するために必要です。必要に応じて、Preston Live Link プラグインまたは Live Link Master Lockit プラグインを使用して、フォーカス、絞り、および焦点距離を UE にストリーミングすることができます。

  1. 新しい Unreal Engine プロジェクトを作成します。[Film, Television, and Live Events (映画、テレビ、ライブ イベント)] カテゴリを選択し、[Next (次へ)] をクリックします。

    Select the Film, Television, Live Events category

  2. Virtual Production」テンプレートを選択し、[Next] をクリックします。

    Select the Virtual Production template

  3. ファイルの場所とプロジェクト名を入力し、[Create Project (プロジェクトを作成)] をクリックします。

    Click Create Project

  4. エディタがロードされたら、 [Settings (設定)] > [Plugins (プラグイン)] の順にクリックして [Plugins (プラグイン)] メニュー を開きます。

    Open the Plugins Menu

  5. [Virtual Production (バーチャル プロダクション)] カテゴリを選択し、Camera Calibration プラグインと LiveLink プラグインをオンにします。ポップアップ ボックスで [Yes (はい)] を選択し、[Restart Now (すぐに再起動)] をクリックしてエディタを再起動します。

    Enable the Camera Calibration plugin

    Enable the LiveLink plugin

    Click Restart Now

このセクションの結果

Camera Calibration プラグインと LiveLink プラグインを有効化して、エディタを再起動しました。これで、キャリブレーション プロセスに進む準備が整いました。

2 - メディア プロファイルを作成する

メディア プロファイル を使用すると、ビデオ ソースの入力と出力、およびタイムコードと同期の形式を設定することができます。このセクションでは、これらのパラメータを設定するための新しいメディア プロファイルを作成します。

レンズの歪みと節点オフセットのキャリブレーションを設定するには、プロダクション カメラのビデオ ソースのみが必要です。タイムコードと同期は必須ではないものの、CG コンポジットをビデオ ソースに同期させるためには、メディア プロファイルでの設定方法を把握しておくことが重要です。

  1. [Media Profile (メディア プロファイル)] > [New Empty Media Profile (新しい空のメディア プロファイル)] の順にクリックして、[Media Profile] ウィンドウを開きます。

    1. [MediaProfile] を選択して、[Select (選択)] をクリックします。

    2. 保存先 のフォルダを選択して、プロファイルの名前を入力します。

    3. [Save (保存)] をクリックします。

      Create a new empty Media Profile

      Select Media Profile

      Enter a name and click Save

  2. [Inputs (入力)][Media Sources (メディア ソース)] カテゴリを展開して、[MediaSource-01] ドロップダウンをクリックします。[Aja Media Source (Aja メディア ソース)] オプションを選択します。

    Select the Aja Media Source option

  3. [AJA] カテゴリを展開して、 [Configuration (設定)] ドロップダウンをクリックします。[Device (デバイス)][Source (ソース)][Resolution (解像度)][Standard (標準)]、および [Frame Rate (フレーム レート)] で選択を行います。[Apply (適用)] をクリックします。

    Choose your configuration

  4. [Timecode Format (タイムコード形式)] ドロップダウンをクリックして、形式を選択します。LTC はビデオ ソースに埋め込まれているタイムコードです。

    Choose your Timecode format

  5. [Is sRGBInput] チェックボックスをオンにして、YUV を RGB に変換します。

    Enable sRGB Input

AJA Kona 5 をマスター クロックに接続し、タイムコードとゲンロックを受信する場合は、 タイムコードの設定 セクションと ゲンロックの設定 のセクションに従います。

タイムコードの設定

  1. [Timecode Provider (タイムコード プロバイダ)] セクションまで下にスクロールします。

    1. [Override Project Settings (プロジェクト設定をオーバーライド)] チェックボックスをオンにします。

    2. [Timecode Provider] ドロップダウンをクリックして、リストから [AJA SDI Input (AJA SDI 入力)] を選択します。

    3. [Use Dedicated Pin (専用ピンを使用)] チェックボックスをオンにします (これは、AJA Kona 5 に接続されたブレイクアウト ケーブルの専用 TC ケーブルです)。

      Enter your Timecode Provider settings

  2. [LTConfiguration] ドロップダウンをクリックして展開し、[Device][LTC Index (LTC インデックス)]、および [Frame Rate] を選択します。[Apply (適用)] をクリックします。

ゲンロックの設定

  1. [Genlock (ゲンロック)] セクションまで下にスクロールします。

    1. [Override Project Settings (プロジェクト設定をオーバーライド)] チェックボックスをオンにします。

    2. [Custom Time Step (カスタム タイム ステップ)] ドロップダウンをクリックして、リストから [AJA SDI Input] を選択します。

    3. [Use Reference in (参照を使用)] チェックボックスをオンにします。

      Enter your Genlock settings

  2. [Configuration (設定)] ドロップダウンをクリックして、[Device][Source][Resolution][Standard]、および [Frame Rate] で選択を行います。[Apply] をクリックします。

  3. ツールバーの [Apply][Save] の順にクリックして、変更内容を保存します。

    Apply and Save

このセクションの結果

このセクションでは、新規のメディア プロファイルを作成して、ビデオ ソース入力を設定しました。また、この段階でマスター クロックを使用している場合の同期を行うため、オプションでタイムコードとゲンロックを追加しました。

3 - レンズ ファイルを作成する

レンズ ファイル を使用すると、レンズとカメラの各組み合わせに固有の、歪みと節点オフセットを計算して、格納できます。レンズ、トラッキング オブジェクトの位置、カメラ ボディに変更があった場合は、新しいレンズ ファイルを作成することをお勧めします。

  1. コンテンツ ブラウザ で右クリックして、[Miscellaneous (その他)] > [Lens File (レンズ ファイル)] をクリックし、新しいレンズ ファイルを作成します。

    Create a new Lens File

  2. コンテンツ ブラウザ にある レンズ ファイル をダブルクリックして開きます。

    Open the Lens File

  3. [Viewport Settings (ビューポート設定)] セクションの [Transparency (透過性)] を「0.0」に変更します。これは、ビデオ ソース画像上の CG 要素の透過性を制御します。

    • 透過性が 0 の場合は、CG 要素はすべて非表示です。

    • 透過性が 1 の場合は、CG 要素のみが表示されます。

    Set Transparency to 0.0

  4. [Camera (カメラ)] ドロップダウンをクリックして、リストから接続されているカメラを選択します。[Media Source] ドロップダウンをクリックして、前に作成したメディア プロファイルを選択します。

    Select the Media Profile

  5. [Lens Info (レンズ情報)] セクションで、[Lens Model Name (レンズ モデル名)] に入力します。推奨される命名規則は、カメラ ボディ名と焦点距離を組み合わせたものです。

  6. [Lens Serial Number (レンズのシリアル番号)] (ある場合) を追加します。[Lens Model (レンズ モデル)] を追加します (現在、サポートされているのは球面レンズ モデルのみ)。カメラに一致する [Sensor Dimensions (センサー寸法)] を入力します。

    Enter the Sensor Dimensions

  7. [Save Lens Information (レンズ情報を保存)] をクリックします。

レンズとカメラ ボディの組み合わせごとに、新しいレンズ ファイルを作成する必要があります。

プロパティの概要

[Lens File] ウィンドウの下部には、レンズ ファイルに適用されている現在のプロパティの概要があります。この段階では、ほとんどのプロパティが空白または N/A と表示されています。これらのプロパティは、キャリブレーション プロセスの進行に伴って更新されます。

Summary of properties

このセクションの結果

このセクションでは、新しいレンズ ファイルを作成し、レンズとカメラの情報を追加しました。

4 - Live Link バーチャル サブジェクトを作成する

Live Link バーチャル サブジェクトは、フォーカス、絞り、焦点距離の各値を、これらの値をストリーミングするために使用するデバイスがない場合に、手動で入力するために使用します。Preston MDR ユニット (セクション 7) または Ambient Master Lockit Plus デバイス (セクション 8) を使用してレンズ データを UE にストリーミングする場合は、該当セクションに進んでこれらを設定してください。

このセクションでは、フォーカス、絞り、ズームの各値を手動で入力するために、新しい Live Link バーチャル サブジェクトを作成します。

  1. コンテンツ ブラウザ を右クリックして [Live Link] > [Blueprint Virtual Subject (ブループリントのバーチャル サブジェクト)] を選択します。

    1. ドロップダウンから [LiveLinkCameraRole] を選択し、[OK] をクリックします。

    2. コンテンツ ブラウザ でバーチャル サブジェクト アセットをダブルクリックして開きます。

      Right-click and select Live Link and Blueprint Virtual Subject

      Select the Live Link Camera Role

  2. [+ Variable (+ 変数)] をクリックして新しい変数を追加します。変数の名前を「Focus」にします。[Details] パネルに移動し、 [Variable Type (変数の型)][Float (浮動小数)] に設定します。[Instance Editable (インスタンス編集可能)] チェックボックスを オン にします。

    Add a new variable

    Name it Focus and set it as Float

  3. この手順を 2 回繰り返して、さらに 2 つの浮動小数型の変数を作成し、「Zoom」と「Iris」という名前を付けます。

    Create Zoom and Iris

  4. イベント グラフ 内を右クリックし、「Update Virtual Subject Static Data」を検索して選択します。

    1. Update Virtual Subject Static Data ノードを Event On Initialize ノードに接続します。

    2. Update Virtual Subject Static Data ノードの Static Data ピンを右クリックし、 [Split Struct Pin (構造体ピンを分割)] をクリックします。

      Add Update Virtual Subject Static Data node

      Connect the Update Virtual Subject Static Data node to the Event On Initialize node

      Right-click the Static Data pin and click Split Struct

  5. 以下のように、 [Focal Length (焦点距離)][Aperture (絞り)] 、および [Focus Distance (フォーカス距離)]オン にします。

    Enable Focal Length, Aperture, and Focus Distance

  6. イベント グラフ 内を右クリックし、「Update Virtual Subject Frame Data」を検索して選択します。

    1. Update Virtual Subject Frame Data ノードを Event On Update ノードに接続します。

    2. Update Virtual Subject Frame Data ノードの Frame Data 入力ピンを右クリックし、[Split Struct Pin (構造体ピンを分割)] をクリックします。このイベントはティックごとにトリガーされ、各フレームで利用可能な FIZ データの更新に使用されます。

      Add Update Virtual Subject Frame Data node

      Connect the Update Virtual Subject Frame Data node to the Event On Update node

      Right click the Frame Data pin and click Split Struct

  7. Zoom 変数を Focal Length 入力ピンに接続します。

    1. Iris 変数を Aperture 入力ピンに接続します。

    2. Focus 変数を Focus Distance 入力ピンに接続します。

    3. ブループリントを コンパイル して、保存 します。

      Add Update Virtual Subject Frame Data node

このセクションの結果

このセクションでは、新しい Live Link バーチャル サブジェクトを作成して、CineCamera アクタへのフォーカス、絞り、ズームの手動での入力に使用できるように設定しました。

5 - Live Link にソースを接続する

このセクションでは、Live Link を使用して、バーチャル サブジェクトとカメラのトラッキングに使用する Optitrack ソースを接続します。

  1. [Window (ウィンドウ)] > [Live Link (ライブリンク)] をクリックして、 [Live Link] ウィンドウを開きます。

    Open the Live Link window

  2. カメラ トラッキングを追加するには、[+ Source (+ ソース)] > [OptiTrack Source (OptiTrack ソース)] をクリックして、[Create (作成)] をクリックします。

    Create a new OptiTrack Source

    The OptiTrack appears on the list

  3. Live Link バーチャル サブジェクトを追加するには、[+ Source] > [Add Virtual Subject (バーチャル サブジェクトを追加)] をクリックします。前のセクションで作成した バーチャル サブジェクト を選択して、[Add (追加)] をクリックします。

    Add a Virtual Subject

    Select your Virtual Subject from the list

  4. [Focus (フォーカス)][Iris (絞り)][Zoom (ズーム)] の各値を手動で入力するには、[Live Link] ウィンドウで [Virtual Camera (バーチャル カメラ)] を選択して、[Default (デフォルト)] セクションで値を入力します。

    Enter the Focus, Iris, and Zoom values

  5. [World Outliner (ワールド アウトライナー)][CineCamera Actor] を選択し、 [Details (詳細)] パネルを開きます。[+ Add Component (コンポーネントを追加)] をクリックして、LiveLinkComponentController を検索して選択します。このコンポーネントの名前を「LiveLinkComponentControllerFiz」に変更します。

    Add a Live Link Controller component

  6. [Details] パネル内の [Live Link] セクションまで下にスクロールして、[Subject Representation (サブジェクトの表現)] ドロップダウンをクリックします。リストから Virtual Camera を選択します。

    Add a Live Link Controller component

  7. 前述の手順を繰り返して、Live Link Controller コンポーネントをもう 1 つ追加し、名前を「LiveLinkComponentControllerTracking」に変更します。

  8. [Details] パネルで、[Subject Representation] ドロップダウンをクリックします。リストから物理カメラを選択します。この例では、Motive から Live Link を介してストリーミングされている Alexa_LF_A を選択します。

    Add your camera

このセクションの結果

このセクションでは、Live Link のバーチャル サブジェクトと Optitrack Live Link を CineCamera アクタに接続しました。

6 - 時間制限データ モニターで同期とタイムコードを評価する (オプション)

これは、Kona 5 でタイムコードと同期を使用し、ソース入力を評価する必要のあるユーザー向けのオプションのセクションです。また、タイミング オフセットおよびバッファを調整して、CG 要素がビデオ ソースやトラッキング データと同期していることを確認することができます。

  1. [Settings (設定)] > [Plugins (プラグイン)] の順にクリックして [Plugins] メニュー を開きます。

    Open the Plugins Menu

  2. [Virtual Production] カテゴリを選択して、Timed Data Monitor プラグインをオンにします。ポップアップ ボックスで [Yes (はい)] を選択して、[Restart Now (すぐに再起動)] をクリックしてエディタを再起動します。

    Enable the Timed Data Monitor plugin

  3. エディタが再ロードされたら、[Window (ウィンドウ)] > [Developer Tools (デベロッパー ツール)] > [Timed Data Monitor (時間制限データ モニター)] をクリックして、[Timed Data Monitor] ウィンドウを開きます。Timed Data Monitor は、さまざまなデバイスの同期とタイムコードを監視するために使用します。また、デバイスのタイムコード プロパティを評価することで、受信データにバッファおよびオフセットを使用してデバイスを同期させることができます。

  4. [Eval Mode (評価モード)][Timecode (タイムコード)] に変更して、[Global TC Offset (グローバル TC オフセット)] の値を入力します。この例では、トラッキング システムと AJA からのビデオ入力を同期するために、グローバル TC オフセット値として 3 フレームを入力しました。また、トラッキング システムのバッファ サイズを 50 に増加しました。

    Change the Eval Mode and enter the Global TC Offset

ウィンドウの上部に、メディア プロファイルで設定された AJA に接続された受信の同期とタイムコードが表示されます。

このセクションの結果

このセクションでは、Timed Data Monitor プラグインを使用して Kona 5 のタイムコードとグローバル TC オフセットを設定する方法について学習しました。

7 - Preston システムを接続する (オプション)

プロダクション カメラに Preston システムを使用している場合は、「Preston システムを接続する」ガイドの手順を実行します。

8 - Master Lockit Plus を使用してスマート レンズを接続する (オプション)

Ambient Master Lockit Plus デバイスを使用してスマート レンズを接続している場合は、「Master Lockit システムを接続する」ガイドの手順を実行します。

9 - レンズの歪みを計算する

レンズの歪みを計算するには、出力された実際のチェッカーボードをプロダクション カメラの視野に入るように硬質のサーフェス上に設置する必要があります。タブレットに表示されたチェッカーボードの画像を使用することもできます。実際のチェッカーボードのプロパティに一致する CG チェッカーボードが作成されます。

  1. [Place Actors (アクタの配置)] タブで、[Virtual Production] カテゴリをクリックして、Checkerboard アクタをレベルにドラッグします。

    Add a Checkerboard actor to your level

  2. [World Outliner] ウィンドウで Checkerboard アクタを選択します。

    1. [Details] パネルに移動し、[Calibration (キャリブレーション)] セクションまで下にスクロールします。

    2. [Num Corner Rows (行のコーナー数)] を入力します。

    3. [Num Corner Columns (列のコーナー数)] を入力します。

    4. [Square Side Length (正方形の辺の長さ)] を cm 単位で入力します。

    5. これらの値は、使用している実際のチェッカーボードと一致している必要があります。

    Add the Rows, Columns, and Square Side Length

  3. 上の例では、行のコーナーが 7 個、列のコーナーが 11 個ある実際のチェッカーボードを使用しています。正方形の各辺の長さは 4.5cm です。この画像では、例で使用したチェッカーボードを表示します。

    Example checkerboard used

  4. 最初、チェッカーボードにはマテリアルが割り当てられていません。[Odd Cube Material (奇数のキューブ マテリアル)] ドロップダウンおよび [Even Cube Material (偶数のキューブ マテリアル)] ドロップダウンをクリックして、目的のマテリアルを選択します。実際のチェッカーボードが左上の黒い正方形から始まる場合は、マテリアルは [Odd Cube Material (奇数のキューブ マテリアル)] の色になります。

    Add the Even and Odd Materials

  5. [World Outliner] ウィンドウで [CineCamera Actor] を選択します。

    1. FIZ データを受け取るために前に作成した Live Link Controller コンポーネントを選択します。

    2. [Details] パネルに移動して、[Camera Role (カメラの役割)] ドロップダウンまで下にスクロールし、開きます。

    3. [Camera Calibration (カメラのキャリブレーション)] セクションまで下にスクロールして、[Lens File (レンズ ファイル)] ドロップダウンをクリックし、先程作成した レンズ ファイル を選択します。

      Enter the Sensor Dimensions

  6. コンテンツ ブラウザレンズ ファイル をダブルクリックして開き、[Lens Distortion (レンズの歪み)] タブをクリックします。

  7. 次のように、カメラの前にチェッカーボードを配置します。

    Place a checkerboard in front of the camera

  8. [Lens Distortion] セクションに移動します。

    1. [Lens Distortion Algo (レンズの歪みアルゴリズム)] ドロップダウンをクリックして、[Lens Distortion Checkerboard (レンズの歪みチェッカーボード)] を選択します。

    2. [Checkerboard (チェッカーボード)] ドロップダウンをクリックして、前に作成した Checkerboard アクタ を選択します。

    3. [Show Detection (検出を表示)] チェックボックス** をオンにします。これで、レンズの歪みの計算に使用する画像が作成されるたびに、プレビュー画像が作成されます。

      Select the distortion algorithm and checkerboard actor

  9. ビューポートをクリックして、キャリブレーション プロセスを開始して、使用する最初の画像を作成します。

    Place a checkerboard in front of the camera

  10. チェッカーボードをカメラの視野角周辺を移動させて、引き続き画像をクリックしてキャリブレーション画像を撮影します。チェッカーボードの位置は、重なり合う画像で視野角をカバーできる十分な回数を移動させてください。

    Take several pictures of the checkerboard at different locations and angles

  11. 十分な数の画像を (4 個以上必要) を収集したら、[Add To Lens Distortion Calibration (レンズ歪みキャリブレーションに追加)] をクリックして、[Lens Calibration Info (レンズ キャリブレーション情報)] ダイアログボックスで [OK] をクリックします。

    Use the Lens Distortion Checkerboard algorithm

    Click OK to confirm the Lens Calibration Info

  12. これで、ウィンドウの下部で [Distortion Parameters (歪みパラメータ)] が更新されていることを確認できます。

    Distortion Parameters update in the window

ほとんどのレンズで、焦点距離が異なると歪み値も異なります。レンズ歪みの最も正確なレンズ ファイルを作成するためには、このプロセスを異なる焦点距離で繰り返す必要があります。

このセクションの結果

このセクションでは、CG チェッカーボードを物理チェッカーボードに一致するように設定して、実際のチェッカーボードの画像をキャプチャし、キャプチャした画像を使用してレンズ ファイルとカメラにレンズ歪みキャリブレーション データを追加しました。オプションで、焦点距離ごとに変わる歪みプロファイルを作成しました。

10 - レンズの歪みを確認する

レンズの歪みを確認するには、[Nodal Offset (節点オフセット)] タブを使用します。この場合、シーンでトラッキングされていない CG チェッカーボードがカメラに移動し、ビデオ フィードに重ねられます。CG オーバーレイがビデオ フィードと一致すると、計算を目視で確認できます。

  1. [Nodal Offset] タブをクリックして、[Nodal Offset] セクションに移動します。

    1. [Nodal Offset Algo] ドロップダウンをクリックして、[Nodal Offset Checkerboard (節点オフセット チェッカーボード) を選択します。

    2. [Checkerboard (チェッカーボード)] ドロップダウンをクリックして、Checkerboard アクタ を選択します。

      Set your Nodal Offset Algo and Checkerboard

  2. 画像をクリックして、キャリブレーションのすべてのコーナー データを入力します。[Apply to Calibrator (キャリブレーターに適用)] をクリックします。これにより、CG Checkerboard アクタがカメラに移動します。

    Click Apply to Calibrator

  3. [Viewport Settings (ビューポート設定)] セクションに移動して、[Transparency] の値を 0 から 1 に変更し、Checkerboard Actor がカメラのビューポートの実際のチェッカーボードと一致することを確認します。

    Verify the Checkerboard Actor matches the physical checkerboard

このセクションの結果

このセクションでは、CG Checkerboard Actor をカメラのビューポートの実際のチェッカーボードに一致させることで、レンズの歪みの計算を検証しました。

11 - 節点オフセット キャリブレーション用のトラッキングされるオブジェクトを作成する

節点オフセットは、トラッキングされたカメラの軸と、キャリブレーションされたレンズ/カメラの組み合わせの実際の節点の軸との差を計算します。レンズを変更したり、カメラのトラッキング デバイスを移動させたりする場合は、新しい節点オフセットを計算する必要があります。

Cine Camera に適用する節点オフセットを計算するためには、物理的にトラッキングされたオブジェクトを作成する必要があります。このトラッキングされるオブジェクトの CG モデルを作成する必要があります。この例では、前に使用した実際のチェッカーボードにトラッキング マーカーを追加しています。トラッキングされたチェッカーボードに一致するように CG モデルを作成して、オプティカル トラッキングを設定しました。この CG チェッカーボードを UE にインポートして、次のステップで使用します。

チェッカーボードを使用するのが一般的ですが、必要に応じて任意のトラッキングされたオブジェクトと CG モデルを作成することができます。このプロセスでは、CG モデルにキャリブレーション ポイントを追加する必要があります。トラッキングされたオブジェクトと CG モデルは、相互に一致するように正しく設定する必要があります。

  1. コンテンツ ブラウザ を右クリックして、[Create Basic Asset (基本アセットの作成)] セクションの [Blueprint Class (ブループリント クラス)] を選択します。

    1. [Pick Parent Class (親クラスを選択)] ウィンドウで [Actor (アクタ)] をクリックします。

    2. ブループリントに「Checkerboard_TRK」という名前を付けます。

      Create a new Blueprint Class

      Select the Actor parent class

  2. コンテンツ ブラウザCheckerboard_TRK ブループリントをダブルクリックして開きます。

    1. [Components (コンポーネント)] ウィンドウに移動して [+ Add Component (+ コンポーネントを追加)] をクリックします。

    2. Static Mesh を検索して選択します。

      Add a Static Mesh component

  3. [Details] パネルに移動して、[Static Mesh (スタティック メッシュ)] セクションまで下にスクロールします。[Static Mesh] ドロップダウンをクリックして、リストから Checkerboard_mesh を検索し、選択します。

    Add the Checkboard_mesh Static Mesh

  4. Static Mesh コンポーネントが選択されている状態で、[Components (コンポーネント)] ウィンドウに移動して [+ Add Component (+ コンポーネントを追加)] をクリックします。

    1. Calibration Point を検索して選択します。

    2. コンポーネントに「Top_Left」という名前を付けます。

      Add a Calibration Point component and name it Top_Left

  5. 次に示すように、ビューポート で、Top_Left コンポーネントをチェッカーボードの左上のポイントに配置します。

    Place the Top_Left component on the top left location on the checkerboard

  6. Top_Left コンポーネントを 4 回複製して、複製したそれぞれのコンポーネントに「Bottom_Left」、「Bottom_Right」、「Top_Right」、「Center」という名前を付けます。これらのコンポーネントをチェッカーボード メッシュ上の対応する位置に配置します。ブループリントを コンパイル して 保存 します。ブループリントを コンパイル して、保存 します。

    Place all four components on their corresponding locations

  7. Checkerboard_TRK ブループリントをレベルにドラッグして、[Details] パネルに移動します。

    1. [+ Add Component] をクリックして、LiveLinkController を検索して選択します。

    2. LiveLink Controller コンポーネントを選択して、[Live Link] セクションまで下にスクロールします。

    3. [Subject Representation] ドロップダウンをクリックして、Checkerboard を選択します。

      Add a Live Link Controller component

      Add the Checkerboard as the Subject Representation

このセクションの結果

このセクションでは、新しいCheckerboard アクタを作成して、5 つのキャリブレーション ポイント (Top Left、Bottom Left、Bottom Right、Top Right、Center) を追加しました。

12- 節点オフセットを計算する

節点オフセットは、物理カメラで使用されているレンズの実際の節点を考慮して、CG Cine カメラにオフセットを適用します。

Camera Calibration プラグインでは、物理プロダクション カメラの前の異なる位置にトラッキング対象のオブジェクトを移動させることで、節点オフセットを計算します。この例では、Checkerboard アクタには複数のキャリブレーション ポイントが含まれています。これらのキャリブレーション ポイントを収集して節点オフセットの計算に使用します。

  1. コンテンツ ブラウザ にある レンズ ファイル をダブルクリックして開きます。

    1. [Nodal Offset] タブをクリックして、[Nodal Offset] セクションに移動します。

    2. [Nodal Offset Algo] ドロップダウンをクリックして、[Nodal Offset Points Method (節点オフセット ポイント メソッド)] を選択します。

    3. [Calibrator (キャリブレーター)] ドロップダウンをクリックして、Checkerboard_TRK アクタを選択します。

      Select the Nodal Offset Points Method and the Checkerboard

  2. 各キャリブレーション ポイントの位置に合わせて、ビューポートのチェッカーボード画像をクリックします。たとえば、Bottom_Right Calibration Point に合わせてチェッカーボードの右下隅をクリックします。

    Click the Bottom Right corner on the checkerboard

    この画像をクリックすると、キャリブレーション ポイントが自動的に更新されます。

  3. トラッキング対象のチェッカーボードをカメラの前で 5 ~ 8 か所に移動させて、それぞれの位置でキャリブレーション ポイントを取得します。

  4. 完了したら、[Add To Nodal Offset Calibration (節点オフセット キャリブレーションに追加)] をクリックします。

  5. 適用された節点オフセットのプロパティを確認して、節点オフセットが正しく適用されたことを確認します。

    Check the properties on the bottom right corner of the window

  6. [Transparency] を「0」から「0.5」に変更します。トラッキングされたチェッカーボードの CG 要素が、ライブ ビデオのチェッカーボードと厳密に重なっている必要があります。

    Change the transparency to see how the CG element overlays with the tracked checkerboard

  7. トラッキングされているカメラをパンして、トラッキングされているチェッカーボードの周りを移動させると、CG バージョンがライブ ビデオ フィードの実際のチェッカーボードと正しく重なった状態で維持されます。

  8. タイムコードとゲンロックを設定しないで、Timed Data Monitor を使用して同期を調整すると、移動に伴って CG 要素に遅延が生じる場合があります。カメラの移動を停止すると、再び CG 要素が整列します。

このセクションの結果

このセクションでは、各キャリブレーション ポイントに一致するようにチェッカーボードの画像をクリックして、キャリブレーション ポイントの値を収集しました。トラッキングされたチェッカーボードを移動させてキャリブレーション ポイントを十分収集した後、カメラの親に節点オフセットを適用しました。最後に、CG バージョンのチェッカーボードがビデオ ソースの実際のバージョンと正しく重なっていることを確認することで、節点オフセットが正しいことを確認しました。

LED ウォールのキャリブレーションを行う場合は、「Aruco を使用してカメラ トラッキングを LED ウォールに合わせる」ガイドの手順に従ってください。

Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
閉じる