USD Stage Editor Quick Start

A tutorial on using the USD Stage workflow with your USD data.

Windows
MacOS
Linux

Unreal Engine provides support for USD through the USD Stage Actor and the USD Stage workflow. In this Quick Start guide, you will:

  • Creating the USD Stage Actor.

  • Editing properties using the USD Stage Window.

  • Adding new Prims to your USD Stage Actor.

  • Writing data back to your USD file.

  • Accessing USD animations using Sequencer.

  • Importing assets into an Unreal Engine project.

Before you begin, you will need the USD Importer plugin enabled in your project. For more information, see Enabling the USD Import Plugin.

Prerequisite Topics

In order to understand and use the content on this page, make sure you are familiar with the following topics:

This tutorial uses the Kitchen Set USD file from Pixar. Pixar maintains a small library of USD sample files for learning and demonstration. Download the Kitchen Set and other samples here.

1. Creating the USD Stage Actor

Start working with USD content by opening the USD Stage window.

The USD Stage window.

  1. In the Unreal Editor, click the Window menu and select the USD Stage.

    Adding the USD Stage window to your view.

  2. From the menu bar in the USD Stage Editor window, select File > Open and navigate to your USD file.

    Opening a file on the USD Stage.

The Hierarchy section will populate with the scene hierarchy being read from your USD file.

The Hierarchy section of the USD Stage window populated with the contents of the Kitchen Set.

Each USD file you open in Unreal Engine requires its own USD Stage Actor that serves as an anchor for your USD data. The process outlined above will automatically add a USD Stage Actor to your Level.

It is also possible to add a USD Stage Actor using the Place Actors panel and select an associated USD file for it using the Root Layer option in the Details panel.

2. Editing Properties Using the USD Stage Window

You can edit the properties of your USD Stage Actor and prims using the Properties section of the USD Stage Editor window.

Editing prim properties using the Properties section of the USD Stage window.

Changing the UpAxis of the USD Stage Actor

  1. Click the Stage at the top of the hierarchy in the USD Stage window.

    Select the Stage option at the top of the hierarchy.

  2. In the Properties section, locate the upAxis property and open the dropdown menu. Select the new axis to represent up for your USD data.

    Select the axis the best fits your USD data.

Changing the Variant of a Prim

  1. In the USD Stage Editor, open the Options > Selection menu and enable Synchronize with Editor. This synchronizes your selection between the Unreal Engine Level and the USD Stage Editor window.

    Enable Synchronize with Editor to synchronize your selection between the USD Stage and the Unreal Engine viewport.

  2. In the Hierarchy section, click the dropdown arrow next to Kitchen_Set. Next, click the dropdown arrow next to Props_grp to display the props in the scene.

  3. Now, expand the DiningTable_grp entry to display the individual prims for the dining table and chairs. Props highlighted in orange indicate that they are composition arcs, and you can right-click any of their prims to add references to them (or clear references from them). Other right-click actions include the ability to add or remove prims, and the ability to toggle, load, or unload payloads.

  4. Select ChairB_1 and look at the properties in the Properties section. From here, you can edit the following:

Property

Description

name

Displays the name of the selected asset.

path

Displays the path of the selected asset.

kind

Defines the type of the selected asset.

  • assembly: Collection of models.

  • component: Type of model that contains subcomponents.

  • group: Collection of models within an assembly.

  • model: Base type of kind. Assets should not have their kind set to model since it is an abstract commonality used to differentiate components and groups. For more information, see Model Hierarchy in the Pixar USD documentation.

  • subcomponent: Prims inside a component. Not a type of model.

purpose

Sets the initial Purpose to load. Uses a USD Stage Actor and an integer as input.

Options include:

  • default

  • proxy

  • render

  • guide

visibility

Sets the initial Purpose to load. Uses a USD Stage Actor and an integer as input.

Options include:

  • inherited: Inherits visibility from its parent

  • invisibile: Prim and any prims included in its subtree are not rendered.

xformOp:rotateZ

Defines the Z rotation of the selected asset.

xformOp:translate

Defines the X, Y, and Z location of the asset.

xformOpOrder

Displays the order in which transform operations are applied to the asset.

modelingVariant

Defines the current variant being displayed in the scene. It will only be visible if the asset has one or more variants.

References

Displays all references attached to this prim.

  1. The chairs in this scene have two variants, ChairA and ChairB. With ChairB_1 selected, find the Variants section of the Properties and change the modelingVariant to ChairA. This will automatically swap the chair mesh used in the scene with the new variant.

3. Adding New Prims to Your USD Stage Actor

Prims are added or removed from the hierarchy using the right-click menu. Once added, their properties can be edited in the Properties section.

Adding a new chair to the Kitchen Set

  1. Right-click the DiningTable_grp entry in the hierarchy and select Add Prim from the menu. Name this new prim ChairB_3.

    Adding a new prim to the USD Stage.

  2. Click your new prim in the hierarchy. In the Details section, change its kind to component.

    Changing the properties of the new prim.

  3. Reference the chair USD file to bring it into the stage. Right-click ChairB_3 in the hierarchy and select Add Reference. Navigate to the location of your Kitchen Set files. Open the assets > Chair folder and select Chair.usd. Click the Open button.

    Adding a Reference to your USD data.

    Selecting the chair data in the File window.

  4. Your new prim now references the Chair USD data and displays the ChairA variant. It should be located at the Level's origin. Select ChairB_3 in the hierarchy and change the modelingVariant to ChairB.

  5. Click the new chair in the viewport and use the transform tools to place the chair near the table.

4. Writing Data Back to Your USD File

Changes made using the USD Stage Actor can be written back to your USD file using the Save option.

Using the Save option in the USD Stage Editor window will write your changes back to the USD file.

To write these changes to your USD file, open the File menu in the USD Stage window and select the Save option.

5. Accessing USD Animations Using Sequencer

Accessing USD Animations

Animations stored within a USD file are accessible from a specifically-generated Level Sequence spawned by the USD Stage Actor.

  1. In the World Outliner, locate the USDStageActor and select it from the list.

    Find the USD Stage Actor in the World Outliner.

  2. In the USD section of the Details panel, locate the Level Sequence and double-click the asset to open Sequencer.

    Double click the Level Sequence in the Details panel.

For more information on using Sequencer, see Cinematics and Sequencer.

Animating the Chair

To add animation to the new prim ChairB_3 that you created in step three, create a new USD file and add it as a layer to the USD Stage Actor.

  1. New animation should be added to a new layer. Creating a new USD layer creates a new USD file. In the Layers section of the USD Stage window, right-click the kitchen_set.usd layer and select Add New.

    Add a new Layer to your USD data for the animation.

    Save this new file as myanim.usda.

  2. USD layers use a LIVRPS structure to determine how layers affect the final composition of the scene. For animation to affect the kitchen set, the layer containing that animation must be higher in the layer structure than the scene containing the prims. Search for the USD Stage Actor in the Place Actors panel and drag a new copy into your Level.

    New USD Actors in the Place Actors panel.

  3. Select the USD Stage Actor in the World Outliner and open your myanim.usda file using the File menu in the USD Stage window.

  4. Add the kitchen set back into the layer stack by right-clicking the myanim.usda layer and selecting the Add Existing option. In the File window, navigate to your kitchen_set.usd file and click Open.

    Add a new Layer using existing USD data.

  5. Before adding the animation, the USD Stage needs to know how long the animation will be. Click the Stage prim in the hierarchy. In the Properties section, change the endTimeCode and endFrame values to 48.

    Change the endTimeCode and endFrame properties.

  6. Select your new USD Stage Actor in the World Outliner and open the Level Sequence in the Details panel.

  7. In the Sequencer panel, click the + Track button and select the Actor you want to animate from the Actor to Sequencer submenu.

    Add a new Track group for the selected Actor.

  8. Click the Add (+) button on the new track and create a new Transform track.

    Add a new Transform track.

  9. Animate the chair rotating in place. For more information on using Tracks in Sequencer, see Tracks.

    Animate the Yaw Rotation track.

  10. Write the data back to USD using File > Save in the USD Stage window.

6. Importing Assets into an Unreal Engine Project

Actors displayed on the USD Stage Actor can be imported into the Unreal Editor's Content Browser through any of the following import options.

  • Using File > Import Into Level. This process will import both assets (static mesh, skeletal mesh, materials, textures, and so on) and Actors.

  • Using the Add/Import button in the Content Browser. This process will only import assets.

  • Dragging and dropping the file into the Content Browser. This process will only import assets.

  • Using the Action > Import option in the USD Stage Editor window. This process will import everything on the USD Stage Actor and works with both assets and Actors. After the import process is complete, assets on the USD Stage are replaced with new Actors from the Content Browser.

Importing the Kitchen Set into Unreal Engine

  1. With the Kitchen Set open in the USD Stage window, open the Actions menu and select Import.

  2. Select the location to store the imported assets. In this example, importing the Kitchen Set will create a folder named Kitchen_set in the selected location. Materials and static meshes are saved into separate subfolders.

언리얼 엔진 문서의 미래를 함께 만들어주세요! 더 나은 서비스를 제공할 수 있도록 문서 사용에 대한 피드백을 주세요.
설문조사에 참여해 주세요
건너뛰기